3

This question already has an answer here:

How can I make it so that the grub start up screen will not show up in debian when I boot?

enter image description here

marked as duplicate by Gilles, Anthon, Bernhard, goldilocks, rahmu Jun 24 '14 at 11:48

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    @Creek nope, that's with GRUB 1, this is with GRUB 2. Completely different configuration. – derobert Jun 18 '14 at 17:10
  • @derobert That question is actually about Grub 2 — not sure why some people posted a Grub 1 answer but the asker was running Grub 2 and the accepted answer describes both. – Gilles Jun 18 '14 at 23:03
  • @Gilles My apologies, with it being an old question, one of the answers only covering grub1, and the other only covering grub2 as an afterthought, I figured it was just grub1. I missed OP's comment. That said, the answer still isn't really over there, as it doesn't say which variable in /etc/default/grub to edit. I guess if we want just one hide grub startup screen question, we should merge the two questions (well, or rather get a mod to merge them for us). – derobert Jun 19 '14 at 18:18
6
  1. Change timeout settings in /etc/default/grub:

    GRUB_TIMEOUT=0
    
  2. Update Grub

    update-grub
    

Not the answer you're looking for? Browse other questions tagged or ask your own question.