4

My question is almost the same as this one but the answer did not work for me.

I'm running OpenSuse 13.1 with XFCE desktop.

I have set ~/.kde4/share/config/kcmfonts with forceFontDPI=0 but it didn't work.

I found on a forum that I could use qtconfig. When I run it, I can change the font size and the sample text now looks readable, but when I quit qtconfig asking to save changes, I get the following error:

X Error: BadAtom (invalid Atom parameter) 5
  Major opcode: 18 (X_ChangeProperty)
  Resource id:  0x0
7
  • Try using systemsettings .
    – schaiba
    Jun 18, 2014 at 12:30
  • @schaiba is this a console command or in Yast? Because I dont have such command
    – remi
    Jun 18, 2014 at 12:34
  • zypper se systemsettings
    – schaiba
    Jun 18, 2014 at 12:35
  • No packages found. I just installed XFCE by the way, not KDE. But cant find it in the kde packages
    – remi
    Jun 18, 2014 at 12:42
  • seems it's in the kdebase4-workspace.
    – remi
    Jun 18, 2014 at 12:44

2 Answers 2

2
  • Try setting it directly in (10 is the font size in the example):

    ~/.config/Trolltech.conf

    [Qt]
    font="Sans Serif,10,-1,5,50,0,0,0,0,0"
    
  • Or for global settings:

    /etc/xdg/Trolltech.conf

3
  • 2
    Didnt work, unless I need a complete reboot ? I changed the font size to 42, restarted a Qt app, but got the same tiny fonts. Same after logging out and back in my xfce session
    – remi
    Jun 18, 2014 at 15:22
  • 1
    +1 every time after relogging the font size in ~/.config/Trolltech.conf resets to original size
    – Ivan Kush
    May 13, 2017 at 19:26
  • What are the other numbers for? May 25, 2020 at 17:47
2

Just found a solution:

  1. OpenSUSE Menu → Settings → Settings Manager (graphical settings manager for xfce4).
  2. In Appearance → Fonts: Check Custom DPI setting and set an appropriate value (96 in my case).

Now, Qt-Based app's have readable fonts!

I remember doing exactly the same thing in the KDE desktop (checking custom DPI) but that did not work when I was login back in my Xfce session.

Not the answer you're looking for? Browse other questions tagged .