1

I am running into a bit of trouble accessing a web application running on port 9293 on a remote server only accessible via ssh on port 5634. I've configured FoxyProxy to route all traffic meeting the remote host's IP address (wildcard white listed like so *remoteip*) to port 1234. The end to this story is it's not working, here is the ssh command I'm running:

ssh -D 1234 user@remoteip -p 5634

Then when I attempt to connect to the web app via the following address, it timesout (ssl is enabled):

https://remoteip:9293

Any ideas where I'm going wrong? Also the remote host is running Debian 7.5, if that's relevant.

1

You should use telnet in order to check if the port forwarding works:

telnet localhost 1234

It's probably not working as you use the wrong SSH options (twice):

ssh -L localhost:1234:remoteip:5634 user@remoteip

or (depending on it on which interface(s) the server is listening:

ssh -L localhost:1234:localhost:5634 user@remoteip

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.