1

I'm using RHEL 6.3 (2.6.32-279.el6.x86_64)
VideoCard: NVIDIA Quadro 410
Installed Graphic Driver: NVIDIA-Linux-x86_64-331.79

I try to run Xserver, but it won't start.

Here is a log file:

cat /var/log/Xorg.0.log
[   641.698]
X.Org X Server 1.10.6
Release Date: 2012-02-10
[   641.699] X Protocol Version 11, Revision 0
[   641.699] Build Operating System: x86-007 2.6.18-308.1.1.el5
[   641.699] Current Operating System: Linux mos120.cadence.com 2.6.32-279.el6.x86_64 #1 SMP Wed Jun 13 18:24:36 EDT 2012 x86_64
[   641.700] Kernel command line: ro root=UUID=af5b1128-71a2-4831-8b80-30c1fe45bcb8 intel_iommu=on rd_NO_LUKS rd_LVM_LV=vg00/lswap LANG=en_US.UTF-8 rd_NO_MD SYSFONT=latarcyrheb-sun16 crashkernel=130M@0M  KEYBOARDTYPE=pc KEYTABLE=us rd_NO_DM
[   641.701] Build Date: 28 March 2012  03:02:14PM
[   641.701] Build ID: xorg-x11-server 1.10.6-1.el6
[   641.702] Current version of pixman: 0.18.4
[   641.702]    Before reporting problems, check https://www.redhat.com/apps/support/
        to make sure that you have the latest version.
[   641.703] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   641.704] (==) Log file: "/var/log/Xorg.0.log", Time: Tue Jun 17 13:45:26 2014
[   641.707] (==) Using config file: "/etc/X11/xorg.conf"
[   641.708] (==) ServerLayout "X.org Configured"
[   641.708] (**) |-->Screen "Screen0" (0)
[   641.708] (**) |   |-->Monitor "Monitor0"
[   641.708] (**) |   |-->Device "Card0"
[   641.708] (**) |-->Screen "Screen1" (1)
[   641.708] (**) |   |-->Monitor "Monitor1"
[   641.708] (**) |   |-->Device "Card1"
[   641.708] (**) |-->Screen "Screen2" (2)
[   641.708] (**) |   |-->Monitor "Monitor2"
[   641.708] (**) |   |-->Device "Card2"
[   641.708] (**) |-->Screen "Screen3" (3)
[   641.708] (**) |   |-->Monitor "Monitor3"
[   641.708] (**) |   |-->Device "Card3"
[   641.708] (**) |-->Input Device "Mouse0"
[   641.708] (**) |-->Input Device "Keyboard0"
[   641.708] (==) Automatically adding devices
[   641.708] (==) Automatically enabling devices
[   641.708] (**) FontPath set to:
        catalogue:/etc/X11/fontpath.d,
        built-ins,
        catalogue:/etc/X11/fontpath.d,
        built-ins
[   641.708] (**) ModulePath set to "/usr/lib64/xorg/modules"
[   641.708] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[   641.708] (WW) Disabling Mouse0
[   641.708] (WW) Disabling Keyboard0
[   641.708] (II) Loader magic: 0x7d6960
[   641.708] (II) Module ABI versions:
[   641.708]    X.Org ANSI C Emulation: 0.4
[   641.708]    X.Org Video Driver: 10.0
[   641.708]    X.Org XInput driver : 12.2
[   641.708]    X.Org Server Extension : 5.0
[   641.708] (--) PCI:*(0:5:0:0) 10de:0fff:103c:094a rev 161, Mem @ 0xee000000/16777216, 0xd0000000/268435456, 0xe0000000/33554432, I/O @ 0x0000c000/128, BIOS @ 0x????????/524288
[   641.709] (II) "extmod" will be loaded. This was enabled by default and also specified in the config file.
[   641.709] (II) "dbe" will be loaded. This was enabled by default and also specified in the config file.
[   641.709] (II) "glx" will be loaded. This was enabled by default and also specified in the config file.
[   641.709] (II) "record" will be loaded. This was enabled by default and also specified in the config file.
[   641.709] (II) "dri" will be loaded by default.
[   641.709] (II) "dri2" will be loaded. This was enabled by default and also specified in the config file.
[   641.709] (II) LoadModule: "dbe"
[   641.714] (II) Loading /usr/lib64/xorg/modules/extensions/libdbe.so
[   641.714] (II) Module dbe: vendor="X.Org Foundation"
[   641.714]    compiled for 1.10.6, module version = 1.0.0
[   641.714]    Module class: X.Org Server Extension
[   641.714]    ABI class: X.Org Server Extension, version 5.0
[   641.714] (II) Loading extension DOUBLE-BUFFER
[   641.714] (II) LoadModule: "extmod"
[   641.714] (II) Loading /usr/lib64/xorg/modules/extensions/libextmod.so
[   641.716] (II) Module extmod: vendor="X.Org Foundation"
[   641.716]    compiled for 1.10.6, module version = 1.0.0
[   641.716]    Module class: X.Org Server Extension
[   641.716]    ABI class: X.Org Server Extension, version 5.0
[   641.716] (II) Loading extension SELinux
[   641.716] (II) Loading extension MIT-SCREEN-SAVER
[   641.716] (II) Loading extension XFree86-VidModeExtension
[   641.716] (II) Loading extension XFree86-DGA
[   641.716] (II) Loading extension DPMS
[   641.716] (II) Loading extension XVideo
[   641.716] (II) Loading extension XVideo-MotionCompensation
[   641.716] (II) Loading extension X-Resource
[   641.716] (II) LoadModule: "dri2"
[   641.716] (II) Loading /usr/lib64/xorg/modules/extensions/libdri2.so
[   641.717] (II) Module dri2: vendor="X.Org Foundation"
[   641.717]    compiled for 1.10.6, module version = 1.2.0
[   641.717]    ABI class: X.Org Server Extension, version 5.0
[   641.717] (II) Loading extension DRI2
[   641.717] (II) LoadModule: "record"
[   641.717] (II) Loading /usr/lib64/xorg/modules/extensions/librecord.so
[   641.718] (II) Module record: vendor="X.Org Foundation"
[   641.718]    compiled for 1.10.6, module version = 1.13.0
[   641.718]    Module class: X.Org Server Extension
[   641.718]    ABI class: X.Org Server Extension, version 5.0
[   641.718] (II) Loading extension RECORD
[   641.718] (II) LoadModule: "glx"
[   641.723] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[   641.819] (II) Module glx: vendor="NVIDIA Corporation"
[   641.819]    compiled for 4.0.2, module version = 1.0.0
[   641.819]    Module class: X.Org Server Extension
[   641.819] (II) NVIDIA GLX Module  331.79  Sat May 17 23:58:32 PDT 2014
[   641.820] (II) Loading extension GLX
[   641.820] (II) LoadModule: "dri"
[   641.820] (II) Loading /usr/lib64/xorg/modules/extensions/libdri.so
[   641.821] (II) Module dri: vendor="X.Org Foundation"
[   641.821]    compiled for 1.10.6, module version = 1.0.0
[   641.821]    ABI class: X.Org Server Extension, version 5.0
[   641.821] (II) Loading extension XFree86-DRI
[   641.821] (II) LoadModule: "nvidia"
[   641.821] (II) Loading /usr/lib64/xorg/modules/drivers/nvidia_drv.so
[   641.828] (II) Module nvidia: vendor="NVIDIA Corporation"
[   641.829]    compiled for 4.0.2, module version = 1.0.0
[   641.829]    Module class: X.Org Video Driver
[   641.830] (II) NVIDIA dlloader X Driver  331.79  Sat May 17 23:37:42 PDT 2014
[   641.830] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[   641.830] (--) using VT number 7

[   641.842] (II) Loading sub module "fb"
[   641.842] (II) LoadModule: "fb"
[   641.842] (II) Loading /usr/lib64/xorg/modules/libfb.so
[   641.843] (II) Module fb: vendor="X.Org Foundation"
[   641.843]    compiled for 1.10.6, module version = 1.0.0
[   641.843]    ABI class: X.Org ANSI C Emulation, version 0.4
[   641.843] (II) Loading sub module "wfb"
[   641.843] (II) LoadModule: "wfb"
[   641.843] (II) Loading /usr/lib64/xorg/modules/libwfb.so
[   641.845] (II) Module wfb: vendor="X.Org Foundation"
[   641.845]    compiled for 1.10.6, module version = 1.0.0
[   641.845]    ABI class: X.Org ANSI C Emulation, version 0.4
[   641.845] (II) Loading sub module "ramdac"
[   641.845] (II) LoadModule: "ramdac"
[   641.845] (II) Module "ramdac" already built-in
[   641.846] (II) Loading /usr/lib64/xorg/modules/drivers/nvidia_drv.so
[   641.846] (II) Loading /usr/lib64/xorg/modules/libwfb.so
[   641.846] (II) Loading /usr/lib64/xorg/modules/libfb.so
[   641.847] (==) NVIDIA(0): Depth 24, (==) framebuffer bpp 32
[   641.847] (==) NVIDIA(0): RGB weight 888
[   641.847] (==) NVIDIA(0): Default visual is TrueColor
[   641.847] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[   641.847] (**) NVIDIA(0): Enabling 2D acceleration
[   642.374] (II) NVIDIA(0): NVIDIA GPU Quadro 410 (GK107GL) at PCI:5:0:0 (GPU-0)
[   642.374] (--) NVIDIA(0): Memory: 524288 kBytes
[   642.374] (--) NVIDIA(0): VideoBIOS: 80.07.47.00.17
[   642.374] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[   642.378] (--) NVIDIA(0): Valid display device(s) on Quadro 410 at PCI:5:0:0
[   642.378] (--) NVIDIA(0):     CRT-0
[   642.378] (--) NVIDIA(0):     DFP-0 (boot)
[   642.378] (--) NVIDIA(0):     DFP-1
[   642.378] (--) NVIDIA(0):     DFP-2
[   642.378] (--) NVIDIA(0): CRT-0: 400.0 MHz maximum pixel clock
[   642.378] (--) NVIDIA(0): DFP-0: Internal Single Link TMDS
[   642.378] (--) NVIDIA(0): DFP-0: 330.0 MHz maximum pixel clock
[   642.378] (--) NVIDIA(0): DFP-1: Internal Single Link TMDS
[   642.378] (--) NVIDIA(0): DFP-1: 165.0 MHz maximum pixel clock
[   642.378] (--) NVIDIA(0): DFP-2: Internal DisplayPort
[   642.378] (--) NVIDIA(0): DFP-2: 960.0 MHz maximum pixel clock
[   642.378] (EE) NVIDIA(0): Failed to assign any connected display devices to X screen 0.
[   642.378] (EE) NVIDIA(0):     Set AllowEmptyInitialConfiguration if you want the server
[   642.378] (EE) NVIDIA(0):     to start anyway
[   642.596] (EE) NVIDIA(0): Failing initialization of X screen 0
[   642.596] (II) UnloadModule: "nvidia"
[   642.596] (II) Unloading nvidia
[   642.596] (II) UnloadModule: "wfb"
[   642.596] (II) Unloading wfb
[   642.596] (II) UnloadModule: "fb"
[   642.596] (II) Unloading fb
[   642.596] (EE) Screen(s) found, but none have a usable configuration.
[   642.596]
Fatal server error:
[   642.596] no screens found
[   642.596]
Please consult the Red Hat, Inc. support
         at https://www.redhat.com/apps/support/
 for help.
[   642.596] Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[   642.596]

Here is xorg.conf:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 331.79  (buildmeister@swio-display-x86-rhel47-09)  Sun May 18 00:42:05 PDT 2014


Section "ServerLayout"
    Identifier     "X.org Configured"
    Screen      0  "Screen0" 0 0
    Screen      1  "Screen1" RightOf "Screen0"
    Screen      2  "Screen2" RightOf "Screen1"
    Screen      3  "Screen3" RightOf "Screen2"
    InputDevice    "Mouse0" "CorePointer"
    InputDevice    "Keyboard0" "CoreKeyboard"
    Option         "AllowEmptyInput" "no"
EndSection

Section "Files"
    ModulePath      "/usr/lib64/xorg/modules"
    FontPath        "catalogue:/etc/X11/fontpath.d"
    FontPath        "built-ins"
EndSection

Section "Module"
    Load           "dbe"
    Load           "extmod"
    Load           "dri2"
    Load           "record"
    Load           "glx"
EndSection

Section "InputDevice"
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "InputDevice"
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/input/mice"
    Option         "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Monitor Vendor"
    ModelName      "Monitor Model"
EndSection

Section "Monitor"
    Identifier     "Monitor1"
    VendorName     "Monitor Vendor"
    ModelName      "Monitor Model"
EndSection

Section "Monitor"
    Identifier     "Monitor2"
    VendorName     "Monitor Vendor"
    ModelName      "Monitor Model"
EndSection

Section "Monitor"
    Identifier     "Monitor3"
    VendorName     "Monitor Vendor"
    ModelName      "Monitor Model"
EndSection

Section "Device"

        ### Available Driver options are:-
        ### Values: : integer, : float, : "True"/"False",
        ### : "String", : " Hz/kHz/MHz",
        ### : "%"
        ### [arg]: arg optional
        #Option     "SWcursor"                  # []
        #Option     "HWcursor"                  # []
        #Option     "NoAccel"                   # []
        #Option     "ShadowFB"                  # []
        #Option     "UseFBDev"                  # []
        #Option     "Rotate"                    # []
        #Option     "VideoKey"                  # 
        #Option     "FlatPanel"                 # []
        #Option     "FPDither"                  # []
        #Option     "CrtcNumber"                # 
        #Option     "FPScale"                   # []
        #Option     "FPTweak"                   # 
        #Option     "DualHead"                  # []
    Identifier     "Card0"
    Driver         "nvidia"
    BusID          "PCI:5:0:0"
EndSection

Section "Device"

        ### Available Driver options are:-
        ### Values: : integer, : float, : "True"/"False",
        ### : "String", : " Hz/kHz/MHz",
        ### : "%"
        ### [arg]: arg optional
        #Option     "SWcursor"                  # []
        #Option     "HWcursor"                  # []
        #Option     "NoAccel"                   # []
        #Option     "ShadowFB"                  # []
        #Option     "UseFBDev"                  # []
        #Option     "Rotate"                    # []
        #Option     "VideoKey"                  # 
        #Option     "FlatPanel"                 # []
        #Option     "FPDither"                  # []
        #Option     "CrtcNumber"                # 
        #Option     "FPScale"                   # []
        #Option     "FPTweak"                   # 
        #Option     "DualHead"                  # []
    Identifier     "Card1"
    Driver         "nvidia"
    BusID          "PCI:5:0:0"
EndSection

Section "Device"

        ### Available Driver options are:-
        ### Values: : integer, : float, : "True"/"False",
        ### : "String", : " Hz/kHz/MHz",
        ### : "%"
        ### [arg]: arg optional
        #Option     "ShadowFB"                  # []
        #Option     "Rotate"                    # 
        #Option     "fbdev"                     # 
        #Option     "debug"                     # []
    Identifier     "Card2"
    Driver         "nvidia"
    BusID          "PCI:5:0:0"
EndSection

Section "Device"

        ### Available Driver options are:-
        ### Values: : integer, : float, : "True"/"False",
        ### : "String", : " Hz/kHz/MHz",
        ### : "%"
        ### [arg]: arg optional
        #Option     "ShadowFB"                  # []
        #Option     "DefaultRefresh"            # []
        #Option     "ModeSetClearScreen"        # []
    Identifier     "Card3"
    Driver         "nvidia"
    BusID          "PCI:5:0:0"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Card0"
    Monitor        "Monitor0"
    SubSection     "Display"
        Viewport    0 0
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       4
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       8
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       15
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       16
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       24
    EndSubSection
EndSection

Section "Screen"
    Identifier     "Screen1"
    Device         "Card1"
    Monitor        "Monitor1"
    SubSection     "Display"
        Viewport    0 0
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       4
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       8
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       15
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       16
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       24
    EndSubSection
EndSection

Section "Screen"
    Identifier     "Screen2"
    Device         "Card2"
    Monitor        "Monitor2"
    SubSection     "Display"
        Viewport    0 0
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       4
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       8
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       15
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       16
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       24
    EndSubSection
EndSection

Section "Screen"
    Identifier     "Screen3"
    Device         "Card3"
    Monitor        "Monitor3"
    SubSection     "Display"
        Viewport    0 0
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       4
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       8
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       15
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       16
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       24
    EndSubSection
EndSection

UPD. Could this be a symptom of the problem? It cannot see the model of the card.

$ lspci -nn | grep VGA
05:00.0 VGA compatible controller [0300]: NVIDIA Corporation Device [10de:0fff] (rev a1)
  • I cleaned up your Q and you rolled backed my edits. Saying thanks and asking for people to please help are phrasing that we typically remove from Q's. Not sure if you're aware or not. Also the list of versions at the top is harder to parse out, better to make that a list as I had previously so it's easier for people to know what version of things you're using. – slm Jun 17 '14 at 12:01
  • I edited my post, but I think all edits done so far is too minor. Anyway do you have an actual answer or some guess on the issue? – Alexander Jun 17 '14 at 12:04
  • I edit to help make the Q's more readable, trying to get more readers to check it out in the hopes of getting you an answer 8-) – slm Jun 17 '14 at 12:07
  • 1
    Try these directions: tecmint.com/install-nvidia-drivers-in-linux – slm Jun 17 '14 at 12:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.