1

Update

I started all over again. This time instead of the one-click button for the drivers I installed nvidia-bumblebee. This works slightly better because now I have my desktop effects back again. Also applications which need OpenGL are up and running again. However I still cannot run glxspheres:

$ optirun glxspheres
Polygons in scene: 62464
libGL error: failed to load driver: swrast
libGL error: Try again with LIBGL_DEBUG=verbose for more details.
Visual ID of window: 0x20
[VGL] WARNING: The OpenGL rendering context obtained on X display
[VGL]    :8 is indirect, which may cause performance to suffer.                                                                                                                                                                                
[VGL]    If :8 is a local X display, then the framebuffer device                                                                                                                                                                               
[VGL]    permissions may be set incorrectly.
Context is Indirect
OpenGL Renderer: GeForce GT 540M/PCIe/SSE2
[VGL] ERROR: in readpixels--
[VGL]    358: GL_ARB_pixel_buffer_object extension not available

Old

I have installed Bumblebee 3.2.1 for openSUSE 13.1 64 bit, unfortunately it is not working properly. The discrete card is OFF as it should, however if I use optirun/primusrun I get the following error:

$ optirun glxspheres64
primus: fatal: broken GLX on main X display

$ primusrun glxspheres64
primus: fatal: broken GLX on main X display

I managed to discover that a symbolic is pointing to a non-existing shared library:

$ cd /usr/lib64/nvidia/xorg/modules/extensions
$ ls -l
$ libglx.so -> /usr/lib64/nvidia/xorg/modules/extensions/libglx.so.331.4x

I do not remember what the exact last digit was, so that's the reason for the trailing x. I changed the symbolic link to point to other similar (existing) shared libraries such as:

  • /usr/lib64/xorg/modules/extensions/libglx.so
  • /usr/lib64/xorg/modules/updates/extensions/libglx.so.331.79

But that did not work (even after a reboot). So I'm out of ideas. Can someone help me out? For the purpose of completeness I will now elaborate on how I installed bumblebee.

How I installed Bumblebee

Output of verifications

$ groups
users wheel video vboxusers bumblebee

# ls /proc/acpi/bbswitch
/proc/acpi/bbswitch

# cat /proc/acpi/bbswitch
0000:01:00.0 OFF

# systemctl status bumblebeed
bumblebeed.service - Bumblebee C Daemon
Loaded: loaded (/usr/lib/systemd/system/bumblebeed.service; enabled)
Active: active (running) since Mon 2014-06-16 17:15:54 CEST; 31min ago
Main PID: 730 (bumblebeed)
CGroup: /system.slice/bumblebeed.service
        └─730 /usr/sbin/bumblebeed

Jun 16 17:26:21 izanagi bumblebeed[730]: [45B blob data]
Jun 16 17:26:21 izanagi bumblebeed[730]: Try '/usr/bin/mknod --help' for more information.
Jun 16 17:26:22 izanagi bumblebeed[730]: [  642.964255] [WARN][XORG] (WW) Unresolved symbol: fbGetGCPrivateKey
Jun 16 17:26:22 izanagi bumblebeed[730]: [  642.964294] [ERROR][XORG] (EE) NVIDIA(0): Failed to initialize the GLX module; please check in your X
Jun 16 17:26:22 izanagi bumblebeed[730]: [  642.964301] [ERROR][XORG] (EE) NVIDIA(0):     log file that the GLX module has been loaded in your X
Jun 16 17:26:22 izanagi bumblebeed[730]: [  642.964307] [ERROR][XORG] (EE) NVIDIA(0):     server, and that the module is the NVIDIA GLX module.  If
Jun 16 17:26:22 izanagi bumblebeed[730]: [  642.964313] [ERROR][XORG] (EE) NVIDIA(0):     you continue to encounter problems, Please try
Jun 16 17:26:22 izanagi bumblebeed[730]: [  642.964319] [ERROR][XORG] (EE) NVIDIA(0):     reinstalling the NVIDIA driver.
Jun 16 17:26:22 izanagi bumblebeed[730]: [  642.964329] [WARN][XORG] (WW) NVIDIA(0): Unable to get display device for DPI computation.
Jun 16 17:26:22 izanagi bumblebeed[730]: [  643.080318] [ERROR][XORG] (EE) Server terminated successfully (0). Closing log file.

$ optirun --status
Bumblebee status: Error (3.2.1): [XORG] (EE) Server terminated successfully (0). Closing log file.
2

Try primusrun instead

primusrun glxspheres

You should also find out, if possible, what package that link belongs to; though, I'm assuming the package is already uninstalled. Therefore, try:

rm -rf /usr/lib64/nvidia/xorg/modules/extensions/libglx.so
  • Wow thanks primusrun works! It didn't before when I installed different drivers. – Aeronaelius Jun 17 '14 at 11:55
  • I'm assuming there were some leftover files/symlinks from your previous nvidia-driver installation, which may have been responsible for tripping up the xorg-server. I'm glad it works now :D – ILMostro_7 Jun 17 '14 at 12:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.