2

I've installed gentoo on my new laptop. I've got an LUKS-encrypted root partition (/dev/sda3). Cryptsetup (USE="gcrypt") is installed. Essential cryptographic API is compiled in kernel. Kernel and initrd image are built using genkernel-next (--luks --gpg).

I use GRUB2 and these kernel options: root=/dev/ram0 crypt_root=/dev/sda3 real_root=/dev/mapper/root rootfstype=ext4

I also tried to omit rootfstype, and root=/dev/mapper/root (no real_root), but nothing has changed.

When I boot my system it asks me for my password:

Enter passphrase for /dev/sda3: ... and after I type (in)correct password nothing happens: I can type any symbol infinitely.

Any ideas? I can boot with live-cd and successfully mount this encrypted volume with cryptsetup.

1

The problem was solved by rebuilding initrd image using genkernel-next with --lvm option.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.