1

As I was running out of space on my Raspberry PI, I picked up another SD card. The 'old' card was only 4GB, the new one is 8GB.

I made an image with Win32DiskImage and wrote this to the 8GB card. Everything went well. But, I discover that actually nothing was happend, so still 4GB... I checked out the web and discover that this is quite normal. So, I searched for a 'how to'. And I found one: click.

So, I followed this tutorial, or at least I tried so. It looks like my SD card layout isn't the same at all. But, I tried to so with: /dev/mmcblk0p6 . But didn't work out, so I re-wrote the image to the SD card. By the way, I installed Raspbian using the NOOBS method.

Some more information:

df -h gives:

pi@raspberrypi:~$ df -h
Filesystem      Size  Used Avail Use% Mounted on
rootfs          3.4G  3.0G  216M  94% /
/dev/root       3.4G  3.0G  216M  94% /
devtmpfs        215M     0  215M   0% /dev
tmpfs            44M  268K   44M   1% /run
tmpfs           5.0M     0  5.0M   0% /run/lock
tmpfs            88M     0   88M   0% /run/shm
/dev/mmcblk0p5   60M  9.4M   50M  16% /boot

fdisk /dev/mmcblk0 gives:

pi@raspberrypi:~$ sudo fdisk /dev/mmcblk0

Command (m for help): p

Disk /dev/mmcblk0: 8072 MB, 8072986624 bytes
4 heads, 16 sectors/track, 246368 cylinders, total 15767552 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00004bf1

        Device Boot      Start         End      Blocks   Id  System
/dev/mmcblk0p1            8192      240234      116021+   e  W95 FAT16 (LBA)
/dev/mmcblk0p2          245760     7663615     3708928   85  Linux extended
/dev/mmcblk0p3         7663616     7729151       32768   83  Linux
/dev/mmcblk0p5          253952      376831       61440    c  W95 FAT32 (LBA)
/dev/mmcblk0p6          385024     7663615     3639296   83  Linux

Command (m for help): q

pi@raspberrypi:~$

parted /dev/mmcblk0 gives:

pi@raspberrypi:~$ sudo parted /dev/mmcblk0
GNU Parted 2.3
Using /dev/mmcblk0
Welcome to GNU Parted! Type 'help' to view a list of commands.
(parted) unit chs
(parted) print
Model: SD F0F0F (sd/mmc)
Disk /dev/mmcblk0: 1955,38,37
Sector size (logical/physical): 512B/512B
BIOS cylinder,head,sector geometry: 1955,128,63.  Each cylinder is 4129kB.
Partition Table: msdos

Number  Start      End        Type      File system  Flags
 1      1,2,2      29,101,15  primary   fat16        lba
 2      30,60,60   950,44,43  extended
 5      31,62,62   46,93,28   logical   fat32        lba
 6      47,95,31   950,44,43  logical   ext4
 3      950,44,44  958,60,59  primary   ext4

(parted)

So, any help is welcome...

0

You should be able to extend the partition by shell programs (fdisk, parted, resize2fs etc.), but I think you can use simple solution as that: put SD card into standard PC with Linux or start the PC with GParted (from USB stick) and then extend the partition in GParted GUI. Can't find more simple solution. It is "demanding" but nice and easy.

  • Well, actually this was indeed the solution that I had in mind as well. But as my laptop didn't like to boot an olld Ubuntu Live CD, I had a problem. So, I tried to find a solution for that. I even installed a VM on my Laptop, but wasn't able to attach the SD card to my VM. (Windows...) So, today I went to the store and bought a card read, attached it to my desktop, booted the Live CD: done – Write Down Jun 14 '14 at 21:44
  • In Windows there is app "Rufus" which makes bootable USB sticks very easy - especially Linux-like (GParted also). No need to use CDs/DVDs nowadays. Glad to help. – pbies Jun 14 '14 at 22:18
  • I know, but that's not the problem. The issue is that for some reason my laptop doesn't accept to boot from other devices then from the Windows Bootloader (even with fastboot disabled). Can't find a way to bypass this issue. If I need to install Ubuntu or something, I use always use a USB. But for rescuing (or things like this) I use my old-fashioned Ubuntu 10.04 official CD. It still like the nice print on the CD. Good old times :-) – Write Down Jun 14 '14 at 23:43
  • @WriteDown Maybe you have Secure Boot set in BIOS setup. – pbies Oct 31 '14 at 19:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.