I'm running Grub .97 with an OpenSuSE 11.2 and Windows XP installation. I configure the grub password in OpenSuSE 11.2 via the Boot Loader module. However, when I type in the password in grub, during bootup, I simply get a Failed message. I have tried about three or four different passwords. I can boot up, I just can't use the password to edit anything about grub.

I have also tried setting the grub password via the command line by typing grub to go to the interactive menu, typing md5crypt, typing my password, and copying the hashed password to the menu.lst file. Still no luck when I enter the password.

  • 1
    Are you absolutely sure you're typing the password right? If you aren't using a US keyboard layout, have you declared your layout to Grub? May 24, 2011 at 16:17
  • @Gilles, good question and of course the obvious one to be asked. To ensure that typing the password wasn't an issue, I changed to a much simpler one on a temporary basis. Yes, I am using the keyboard layout.
    – Chance
    May 24, 2011 at 17:37
  • U.S. keyboard layout that is.
    – Chance
    May 24, 2011 at 17:46

1 Answer 1


I found the answer to my problem here. If I use the md5crypt command to generate my password, I need to enter --md5 between my password and the encrypted password. Now this works.

So, before the title entries in my /boot/grub/menu.lst file I have the line with a password. This now reads

password --md5 encrypted_password.

Based on my experience, it appears that setting the password for the Boot Loader via YaST does not work correctly for OpenSuSE 11.2. I have not yet checked to see if adding a --md5 to the encrypted password provided by YaST would cause it to work, I've only tried the md5crypt method with this.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .