7

Usually, when I log into a website with username and password, Firefox asks whether it should remember the login details. When I click yes, next time I visit the website, the username and password fields are pre-filled, so that I can just click "OK"

But on some websites, I don't get the option to remember the password, and the username and password fields are empty. Alternatively, only the username field is pre-filled, while the password field is empty.

Is there a way to override this, so that I can always choose to save the passwords?

UPDATE:

Preferably, I would like to achieve this without having to install yet another addon. I don't understand how websites tell the browser to not remember passwords, but whatever it is, it should be configurable. Perhaps via userContent.css and userChrome.css ?

  • I have pondered this as well. Some sites have that issue, in some cases the password field doesn't appear to be recognized as such. Potentially it could be possible that the browsers have this "knowledge" hardcoded as a heuristic taking into account the name of the field etc. Opera has the same issue. – 0xC0000022L Jun 12 '14 at 18:36
  • There is an "autocomplete" option in fields that can be disabled, as show in w3schools.com/tags/att_input_autocomplete.asp This, among other things, can be used to stop password saving. – Falsenames Jun 23 '14 at 18:19
  • 1
    @Falsenames - how can I use that information to solve my problem ? – Martin Vegter Jun 23 '14 at 20:32
  • 1
    That is essentially just explaining what @Gilles was getting at with the Greasemonkey script. There are other things done to stop the password autofill, such as having a session key tied in with a password field's name, so it is unlikely to come up again. Enabling autocomplete will likely work on most sites, but people can get pretty creative when blocking passwords from autosaving if it is considered a security risk. – Falsenames Jun 23 '14 at 21:34
3

For Firefox, there's an extension that I use (https://addons.mozilla.org/en-US/firefox/addon/saved-password-editor/) that helps extend the built-in password functionality.

You can manually train it to work on a particular page, but sometimes the way a page is written prevents that. But I have noticed that some that otherwise wouldn't work, do work, so give it a try.

3

If you already have Greasemonkey (who doesn't?), you may be able to get away without another extension. Try creating a userscript that changes autocomplete="off" to autocomplete="on":

// ==UserScript==
// @name           autocomplete on
// @namespace      Martin Vegter
// @description    Forcibly turns autocomplete on
// @include        *://*/*
// #exclude        https://mybank.example.com/*
// ==/UserScript==
document.querySelector("#foo_user").setAttribute("autocomplete", "on");
document.querySelector("#foo_pass").setAttribute("autocomplete", "on");

It worked for me with some sites, but not all of them. I don't know what makes those sites different.

To install this script, the easiest way is to save it to a file called autocomplete-on.user.js and open it in Firefox (firefox autocomplete-on.user.js from the command line). In the newly created tab, press “Install script” and confirm with the “Install” button. You can remove the original autocomplete-on.user.js file (it's copied to your profile).

  • well, I am not using Greasemonkey. But your approach looks interesting nevertheless. But I would still prefer a solution that does not need any addon. – Martin Vegter Jun 13 '14 at 12:45
  • and where should I put the script, after I have installed Greasemonkey ? – Martin Vegter Jun 22 '14 at 19:17
  • @MartinVegter edited. – Gilles 'SO- stop being evil' Jun 22 '14 at 19:33
  • 1
    thanks for the instructions. But even with this script, those websites that did not remember passwords before, do not remember them now – Martin Vegter Jun 22 '14 at 20:54
  • @MartinVegter Unfortunately, some sites prove resistant to forcing autocomplete on. I solved this with Autofill, which isn't nice because my passwords end up in that extension's configuration instead of the browser's dedicated password store. – Gilles 'SO- stop being evil' Jun 22 '14 at 21:04
1

As noted by @Gilles, you can use javascript to turn the autocomplete=off field to autocomplete=on. Take a look at this MozillaZine article, which also suggests using this bookmarklet to have firefox password manager ask you to remember the password after submitting your login info. The MozillaZine article also provides alternative javascript code based on the bookmarklet's code for custom situations and preferences; though, I'm not sure if you can somehow adapt the js-code into your userChrome.css file. :-/

One more thing: Check in your about:config page for signon.storeWhenAutocompleteOff, and make sure it's set to true.

Finally, check out this pertinent question on StackOverflow and see if it helps; otherwise, try asking there for more responses, as your issue might be better suited for that audience.

  • there is no signon.storeWhenAutocompleteOff in my about:config. Where did you see it? – Martin Vegter Jun 22 '14 at 16:38
  • 1
    I'm using Firefox Aurora 31; search for autocomplete in the about:config tab. – ILMostro_7 Jun 23 '14 at 8:03
  • @MartinVegter: in the latest stable FF (30.0) I also have it. – 0xC0000022L Jun 24 '14 at 9:35
0

To expand upon @Gilles answer. Some sites I've encountered, won't save passwords because the user and password fields are not enclosed in a form. I've created this userscript to handle such cases:

https://github.com/JavierParra/userscripts/blob/master/forceRememberPassword.user.js

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.