6

I've been having a weird issue with Alsa recently. For some reason all sounds are really distorted and no matter what application I use, I won't get anything clear out of it. I've tried Tomahawk, Spotify, Youtube and local files played via VLC, and all of them output the same distorted noise. It's impossible to listen to music with all the popping and crackling. Also if I pause the music playing it'll lag behind and won't stop before seconds later.

Youtube does surprisingly output the best results and I can actually hear what song it is, but it's still too bad for listening and would obviously not be a fix to just use that.

I have a MSI Z97 MPower motherboard (which I believe uses Intel HDA for sound) and a i5 4670k. I use a headset, the Sennheiser PC350. No other sound devices are connected but the headset. The distro I use is Arch.

What could cause an issue like this?

9

And fixed!

When looking around, the issue arised when I installed GDM to handle logins, which of course has Gnome attached to it, which in turn requires Pulseaudio. That set my default device to Pulseaudio which messed stuff up.

What I did to solve my problem was to edit /etc/pulse/daemon.conf. Uncomment the following line default-sample-rate = 42100 and change the sample rate to 48000. If changing the sample rate is a fix or not, I'm not sure, but that's one of the things I did.

I also turned off Pulseaudio's "Timer Based Scheduling" by editing /etc/pulse/default.pa and adding tsched=0 to the following line, load-module module-udev-detect tsched=0

  • For me, just adding tsched=0 addressed popping when listening to Spotify – Outfast Source Apr 29 '15 at 12:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.