1

Does anyone know why it is so? I was using unity... then i switched to LXDE and it wont run. I checked the requirements and it turned out that it requires either GNOME or KDE.

So what exactly is it that the 2 DEs offer that LXDE and the others dont? what makes it compatible with gnome and kde but not with the others?

1 Answer 1

1

This may not actually be the case, since LXDE can usually run Gnome programs.

It is possible that PHPStorm specifically calls functions only present in KDE and Gnome, but I have found some evidence of users getting JetBrains applications to run in LXDE (see below).

It think that KDE and Gnome are only listed as "required" because they are the only display managers that have been tested and documented to work by JetBrains. In that case, a requirement for them lowers support and testing costs.

In your case, there must be some library not being loaded or installed in LXDE that in Gnome or KDE loads by default. If you can figure out which ones and have them run at startup, it should start working.

Or, you may be using the wrong version of JDK (official Sun/ Oracle Java is required).

Here is some unofficial, unverified evidence from the web that PhpStorm (or related products like IntelliJ, which use the same framework) run in LXDE:

1. A quote from a JetBrains blog comment:

PhpStorm is not only ahead of the pack, it’s taking ground fast!

Btw, UI looks beautiful in Linux now. Download page says only Gnome and KDE are supported, but it works great in LXDE inside my VirtualBox VM.

2. A generic tutorial for installing IntelliJ IDEA 13 community edition on Lubuntu 12.10

3. A comment in a JetBrains Plugin by mglanvill on 2012-11-21 14:42:58. The user has a problem with the plugin, which presumably means he was able to launch IntelliJ to get that far.

... Another thing, I use intellij on Lubuntu (Linux)....

3
  • THat's all great.. but when i tried it, I was using LXDE on ubuntu.. Plus i had a whole lot of DEs including GNOME and Unity installed.. that meant all their components too.. YET, it failed to work under LXDE.. but worked seamlessly in gnome and unity Dec 15, 2014 at 13:28
  • Ah, that's too bad then. Does it give you any errors when run from the command line? Dec 15, 2014 at 19:17
  • I'm not sure.. I dont recall ever trying. Dec 22, 2014 at 15:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .