5

In some WiFi networks, consistently in hotels so far, my computer cannot connect and prompts that authentication failed, when the password is correct. This is a very annoying problem that I don't know how to fix. I think it happened in Ubuntu a while back and Fedora 20 now. The card is Intel 7260. If anybody could help that would be great.

Added paste of journalctl log: http://pastebin.com/tKcJBPWT

  • 5
    Please ad more info: types of authentication, logs from NetworkManager or journalctl... – dawud Jun 16 '14 at 17:47
  • @dawud Thanks, I can't print logs because I'm on my tablet (no internet), but I can answer questions about them. how do I print the log for networkmanager? The type of authentication in this case is wpa2. – Flowers Jun 19 '14 at 16:43
  • You can try opening journalctl -f in a terminal and try connecting via wi-fi. – dawud Jun 19 '14 at 19:13
  • 1
    Are you sure this isn't one of the hotel WiFi's where you have to browse to a URL and provide the password there? When I've been travelling that's been the case of late. I'm using Fedora 19 BTW. I also have a Thinkpad T410. – slm Jun 20 '14 at 2:41
  • Yes, it was a hotel when I posted but the same problem is now happening in my grandpa's apartment. – Flowers Jun 20 '14 at 6:29
1

This line in the log:

<info> (wlp3s0): device state change: need-auth -> failed (reason 'no-secrets')

means there is no passphrase setup. Add it using:

$ nmcli connection edit polina

once greeted with the nmcli prompt, type:

nmcli> goto 802-11-wireless-security
nmcli 802-11-wireless-security> set psk
Enter 'psk' value: supersecretpassphrase
nmcli 802-11-wireless-security> save
Connection 'polina' (xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxx) sucessfully saved.
nmcli 802-11-wireless-security> back
nmcli> save
Connection 'polina' (xxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx) sucessfully saved.
nmcli> quit

Then you should be able to:

$ nmcli connection up polina

Check the output of journalctl -f while attempting a connection to see if the error is gone.

You can also use the Network Manager graphical interface if you feel more comfortable with it.

| improve this answer | |
  • This didnt work. The password was set up in the first place correctly, but for some reason the computer thinks it's an authentication problem. – Flowers Jun 19 '14 at 20:25
0

Idea #1 - WiFi authentication through Web?

I would be suspicious of the WiFi being provided by the Hotel. When I've traveled I've encountered hotel WiFi where I've had to browse to a web page before I've been able to get on their WiFi. You can check to see if you've gotten an IP address prior to connecting like this:

$ nmcli dev list iface $(iwgetid | awk '{print $1}') | grep IP4
IP4-SETTINGS.ADDRESS:           192.168.1.110
IP4-SETTINGS.PREFIX:            24 (255.255.255.0)
IP4-SETTINGS.GATEWAY:           192.168.1.1
IP4-DNS1.DNS:                   192.168.1.8
IP4-DNS2.DNS:                   192.168.1.5

You'll typically get an IP, but you won't be able to access the internet until you've authenticated with a web portal at the hotel.

Idea #2 - Wireless N?

I'd attempt to disable your WiFi's wireless N feature. You can do so by unloading the WiFi driver and then reload it like so:

$ sudo modprobe iwlwifi 11n_disable=1

See this post for more details on this, titled: WiFi not working after restoring from hibernation (authentication times out).

| improve this answer | |
  • It's not just hotels. I think it has something to do with wpa2. – Flowers Jun 20 '14 at 6:54
  • Thanks, but your second suggestion doesn't fix the problem. Any other thoughts? – Flowers Jun 20 '14 at 9:57
  • @Flowers - can you show the output from iwconfig for the hotel? – slm Jun 20 '14 at 11:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.