2

After a reboot of a CentOS 6.2 server we are getting a kernel panic with the following error:

Kernel panic - not syncing: Attempted to kill init!
Panic occurred, switching back to text console

When passing init=option selinux=0 to the kernel at boot the server will boot without a problem. I have tried searching for what init=option does but I have not been able to find any recourses explaining it.

  • Could someone explain what this parameter does?
  • Also, as this is a production server are there any negatives/risks in running with the init=option?

I have tried to remake the initramfs via dracut which did not work and received the above error upon boot.

As this is a clustered server and the primary server should be identical I have copied the /boot drive from the other server but this did not solve the problem either. (The other server does not have this behavior)

Restoring /boot from backup did not work either.

Could you please help me investigate this problem

  • What causes this kernel panic?
  • How would you go about resolving this issue?
  • What logs (if any) would tell you more information?
  • As this is an older install, would an update/upgrade potentially fix this issue?

I would also like to add that the only other possible related issue was that the root disk which was raid mirrored failed and was replaced before this happened.

bumped to the homepage by Community yesterday

This question has answers that may be good or bad; the system has marked it active so that they can be reviewed.

0

Per the linux kernel parameter docs:

init=option

      init=       [KNL]

          Format: <full_path>

          Run specified binary instead of /sbin/init as init process.

selinux=0

      selinux=    [SELINUX] Disable or enable SELinux at boot time.

          Format: { "0" | "1" }

          See security/selinux/Kconfig help text.

          0 -- disable.

          1 -- enable.

          Default value is set via kernel config option.

          If enabled at boot time, /selinux/disable can be used later to disable prior to initial policy load.

So running with those arguments disables selinux and loads an init daemon called option. So running it this way should not hinder the operation of the system but disabling selinux does come at a security cost. However, if you run init=option without selinux=0 it should boot just fine as selinux should not interfere with init. As for repairing the issue, I have no clue why /sbin/init crashes but the option binary boots just fine so perhaps someone else can edit this answer to include the fix.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.