0

A bit of context: I followed the bug reports on Docky (link1, link2, and all the other links in these links...) and managed to make Plank recognize IntelliJ IDEA using the right StartupWMClass on the .desktop file, it even works in the terminal; typing idea, launches IDEA, with the right icon in the dock, but after I reboot, it doesn't work anymore. What's weirder, if I open idea.desktop with any text editor, and save it, it starts working again until the next reboot, what could be happening?

This is my bash for IDEA, located at /usr/bin/idea:

#!/bin/sh
export IDEA_HOME="/opt/idea-IU-135.909/bin"

$IDEA_HOME/idea.sh $*

My idea.desktop file at /usr/share/applications/idea.desktop:

[Desktop Entry]
Encoding=UTF-8
Name=IntellJ IDEA
Comment=The Best Java and Polyglot IDE
StartupWMClass=jetbrains-idea
Exec=idea
Icon=intellij-idea-ultimate-edition
Terminal=false
Type=Application
Categories=GNOME;Application;Development;
StartupNotify=true

At the moment I've solved this issue by forcing an open & save on my /etc/rc.local like this:

sudo vim /usr/share/applications/idea.desktop
:wq
exit 0

What other options do I have? what could be happening here? is there -at least- a better way to open and save a file in the terminal? mine is imho, horrifying.

  • Create a copy of the non-working version before you open it w/ a text editor, then open & save it and run diff to see if this is something like the addition of a newline at the end of the file. – goldilocks Jun 9 '14 at 14:04
  • Before opening or copying stat the file for all possible permissions related properties, then ^do^, then do the permissions checks again and compare. – mikeserv Jun 9 '14 at 15:50
  • What do you mean by ^do^? – Eddnav Jun 9 '14 at 19:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.