2

When running this on CentOS 6:

yum update

I accept the transaction summary that it presents and am then immediately presented with this:

Downloading Packages:
warning: rpmts_HdrFromFdno: Header V3 RSA/SHA1 Signature, key ID 4520afa9: NOKEY
Retrieving key from file:///etc/pki/rpm-gpg/RPM-GPG-KEY.art.txt

The GPG keys listed for the "CentOS / Red Hat Enterprise Linux 6 - atomicrocketturtle.com" repository are already installed but they are not correct for this package.
Check that the correct key URLs are configured for this repository.

How can I fix this issue?

When I run this:

rpm -q --queryformat "%{SUMMARY}\n" gpg-pubkey

I get this response:

gpg(CentOS-6 Key (CentOS 6 Official Signing Key) <[email protected]>)
gpg(EPEL (6) <[email protected]>)
gpg(Atomic Rocket Turtle <[email protected]>)
gpg(New Relic <[email protected]>)
1
  • yum install package --nogpgcheck
    – Alex
    Commented Nov 18, 2016 at 19:20

5 Answers 5

5

For me, looking into the newer atomic-release package rpm it seems that a new GPG key was added and is in use so if you didn't upgrade for a while you'll likely get this issue.

To fix you need to manually download and import the key and update the repo config:

wget https://www.atomicorp.com/RPM-GPG-KEY.atomicorp.txt
mv RPM-GPG-KEY.atomicorp.txt /etc/pki/rpm-gpg/RPM-GPG-KEY.atomicorp.txt
rpm --import /etc/pki/rpm-gpg/RPM-GPG-KEY.atomicorp.txt

Change /etc/yum.repos.d/atomic.repo. Lines:

gpgkey = file:///etc/pki/rpm-gpg/RPM-GPG-KEY.art.txt

Need an additional entry and become:

gpgkey = file:///etc/pki/rpm-gpg/RPM-GPG-KEY.art.txt
        file:///etc/pki/rpm-gpg/RPM-GPG-KEY.atomicorp.txt
1
  • If the key is imported into the rpm database already, it may not be necessary to add it to the repo file. According to yum.conf(5): gpgkey A URL pointing to the ASCII-armored GPG key file for the repository. This option is used if yum needs a public key to verify a package and the required key hasn't been imported into the RPM data‐ base. If this option is set, yum will automatically import the key from the specified URL. You will be prompted before the key is installed unless the assumeyes option is set.
    – ILMostro_7
    Commented Jul 5, 2018 at 19:11
0

Verify first if the key you have is the right thing installed.

rpm -q --queryformat "%{SUMMARY}\n" gpg-pubkey
2
  • I've added the output of that to the original question.
    – Russ Back
    Commented Jun 9, 2014 at 8:52
  • 1
    My bad. Have you checked if it's one of the GPG keys listed in the Red Hat website? Check it here if your key matches one of those. access.redhat.com/site/security/team/key. Commented Jun 10, 2014 at 5:35
0

try

yum update atomic-release

if that did not work try

wget -q -O - https://www.atomicorp.com/installers/atomic | sh

0

There is at least one error in /.../installers/atomic, on line 327:

rpm -import RPM-GPG-KEY.art.txt >/dev/null 2>&1

Passing the import option to rpm requires two hyphens (--import). Also it should probably check the exit status before echoing OK!

Also, evidence seems to point to a different key file being authoritative.

All that said, I still see the exact same failure even after importing that key file.

0

Well, you need to install the key for the Atomic Repos.

If you access:

http://updates.atomicorp.com/channels/

You will see all the repos available by Atomic Corp. In every repo exists a key, but the fact is that the key is the same for all repos. So, you just need to install one key in your system and add every repo that you wanna use.

To install the key, find the repodata directory for your Linux distribution.

For example:

http://updates.atomicorp.com/channels/atomic/centos/7/x86_64/repodata/

Inside this directory there will be a repomd.xml.key file that is the key that you want.

Download the key:

wget http://updates.atomicorp.com/channels/atomic/centos/7/x86_64/repodata/repomd.xml.key

Then install it:

sudo rpm --import repomd.xml.key

That's all.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .