3

Running Arch/Linux with everything up-to-date and I use network manager's built-in hotspot function to share my Internet.

I'm trying to edit the configuration (mostly the password, as I don't like the random password) for the "hotspot" connection. I've worked on both the network settings GUI and the config file under /etc/NetworkManager/system-connections. Somehow network manager doesn't like this configuration being edited. Every time I change anything and start hotspot again, the edited one will be abandoned, and NM will create a new hotspot connection with default settings and a new random password. How do I tell NM to accept what I've edited?

2

I've had success editing the essid and psk fields in /etc/NetworkManager/system-connections/Hotspot and then restarting NetworkManager with sudo service network-manager restart so that it reads in the new settings.

It seems that as long as this file is still called Hotspot, it will be the configuration used when you start a hotspot from System Settings -> Networking.

NOTE: I've most recently tried this on LMDE, but hopefully it will apply to Arch.

0

If you mean you have activated hostapd, then the password is in /etc/hostapd/hostapd.conf.

  • I'm not running hostapd. The authentication is handled by NM using something. Actually NM and hostapd can get in conflict. If I stop NM from managing WLAN and use hostpd it works well. But using NM's built-in AP is just more convenient. – Mr.Koala Jun 9 '14 at 9:35
0

I wasn't able to get the graphical tools to respect the ssid change, I was able to find a way to setup a wifi access point directly like so:

nmcli dev wifi hotspot ifname wlp4s0 ssid test password "test1234"

credit: https://unix.stackexchange.com/a/384513/61349

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.