1

I had to manually install some dependencies in my fumbling attempts to get netflix working yesterday with pipelight, and ultimately failed. I uninstalled everything I installed during that process, but when I run yum update now I get this:

Transaction Summary
================================================================================
Install             ( 2 Dependent packages)
Upgrade  1 Package

Total size: 442 k
Is this ok [y/d/N]: y
Downloading packages:
Running transaction check
Running transaction test


Transaction check error:
  file /usr/lib/libmpg123.so.0 from install of libmpg123-1.19.0-1.fc19.i686 conflicts with file from package mpg123-1.18.1-1.fc19.i686

Error Summary

Is there a way to get this out of my life without having to do anything drastic?

1 Answer 1

0

The easiest way to fix your problem is to manually install the package (which yum has downloaded into /var/cache/yum/... somewhere) using rpm -Uvh --replacefiles

However you likely have some more "fumbling attempts" ;-) to clean up. Try doing rpm -qa --last | more to see recent activity.

You also should check for duplicated installations.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .