1

I was trying to find out what qalter's -r flag does, but I can't search for -r when viewing the man page for it (pattern not found). Yet it's clearly there. If you scroll down a bit you'll see it. Why can't I search for flags in this man page? This online version seems to work fine though.

  • Works for me, pressing /-r plus Enter. – choroba Jun 8 '14 at 16:22
  • That's what I tried. I'm on gentoo using xfce4-terminal-0.6.3 if that matters. qalter's man page is in the package man-pages-posix-2013a. – Dog Jun 8 '14 at 16:29
  • What about man pages of other commands (e.g. ls)? – choroba Jun 8 '14 at 16:33
  • I tried and it works in ls, gcc and cat. – Dog Jun 8 '14 at 16:47
1

It sometimes happens that man pages contain formatting commands and settings that lead to certain characters being rendered using various non-ASCII characters. This can be instead of |, ­ (soft hyphen) or (hyphen) or (non-breaking hyphen) instead of - (ASCII hyphen-minus), instead of *, etc.

Try searching for non-ASCII characters in the man page:

LC_COLLATE=C LESS='+/[^ -~]' man qalter

You can force the man page to be rendered in ASCII by choosing an ASCII character set:

LC_CTYPE=C man qalter

Having shell options rendered with a non-ASCII alternative to - is a bug, probably in the man page soucre. I don't know enough *roff to know what the bug might be.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.