4

We are using a Debian 7 machine with the default GNOME 3 installation to display content on an information display. This display needs to remain on until the connected computer is switched off. However, GNOME 3 switches the display off after a few minutes.

I can't seem to find a way to control this behaviour in either the system settings tools nor using dconf-editor. There is a prominent Google hit suggesting to change the

org.gnome.settings-daemon.plugins.power sleep-display-ac
org.gnome.settings-daemon.plugins.power sleep-display-battery
org.gnome.desktop.session idle-delay

keys, but this did not change anything.

So, how does one control and disable screen blanking in GNOME 3?

5

Try disabling DPMS and Screen saver:

xset -dpms
xset s off
  • 1
    Use xset +dpms; xset s on to restore the original state. – user44370 Jun 22 '14 at 12:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.