4

I use "Back In Time" which is nothing more than a front end GUI to rsync version 3.0.9 protocol version 30. I'm running ubuntu 12.04.

My backup device is a locally mounted USB flash stick/drive formatted as ext2.

It gives me numerous errors similar to the following...

[E] Error: rsync: mkstemp "/media/apb/0543d632-d24b-4b4e-8ca8-56d22c19e62f/backintime/myhost.mydomain.com/root/4/new_snapshot/backup/home/apb/Documents/7uzyrwsy.default-20131026-1639/Mail/pop-server.bak.rr-8.com/.Sent.msf.RZMdLy" failed: Invalid argument (22)

The command line that Back in Time uses to call rsync:

[I] rsync -rtDH --links --no-p --no-g --no-o  --delete --delete-excluded  -v  
--chmod=Du+wx  --exclude="/media/apb/0543d632-d24b-4b4e-8ca8-56d22c19e62f" 
--exclude="/root/.local/share/backintime" --exclude="/tmp/backintime" 
--include="/home/apb/asterisk/" --include="/home/apb/" --include="/home/" 
--include="/home/apb/Documents/" --include="/home/apb/Linux-Centos/" 
--exclude=".gvfs" --exclude=".cache*" --exclude="[Cc]ache*" 
--exclude=".thumbnails*" --exclude="[Tt]rash*" --exclude="*.backup*" 
--exclude="*~" --exclude="/root/Ubuntu One" --exclude=".dropbox*" 
--exclude="/proc/*" --exclude="/sys/*" --exclude="/dev/*" --exclude="/run/*" 
--include="/home/apb/asterisk/**" --include="/home/apb/Documents/**" 
--include="/home/apb/Linux-Centos/**" --exclude="*" / "/media/apb/0543d632-d24b-4b4e-8ca8-56d22c19e62f/backintime/myhost.mydomain.com/root/4/new_snapshot/backup/"

Any ideas as to what's causing the failure, and better yet... how to fix it?

  • I cannot propose an edit for some reason. But you should read the formatting guide and use code block formatting for any terminal output or code snippets. They are virtually unreadable in dynamic-width fonts. – HalosGhost Jun 7 '14 at 20:34
1

I suspect that the length of this directory/path is the issue. You could test this theory by trying to run these commands:

$ mkdir -p /media/apb/0543d632-d24b-4b4e-8ca8-56d22c19e62f/backintime/myhost.mydomain.com/root/4/new_snapshot/backup/home/apb/Documents/7uzyrwsy.default-20131026-1639/Mail/pop-server.bak.rr-8.com/
$ touch /media/apb/0543d632-d24b-4b4e-8ca8-56d22c19e62f/backintime/myhost.mydomain.com/root/4/new_snapshot/backup/home/apb/Documents/7uzyrwsy.default-20131026-1639/Mail/pop-server.bak.rr-8.com/.Sent.msf.RZMdLy

The first will attempt to make the directory tree, the second will touch the resulting file in this directory.

1

Endless strings of "error (22)" messages on rsync, Grsync, and other rsync-based utilities for file transfers and back-up had me searching repeatedly on the Internet for solutions for almost a month. I used about half a dozen different USB drives; oddly, one of them did not produce any error messages, and a 500-GB, USB-3 hard-disk drive worked perfectly. I tried formatting the flash drives on both my MacBook (about 8 years old) and my HP Pavilion h21 (about 4 months old, on which I was doing this work); neither produced better results.

I finally discovered that the flash-drive formatting utility ("Disks" in Linux Mint) has an option to make the flash drive bootable in the "Edit Partition" option of the adjustments icon (the double gear, labelled "More Actions"). I selected that option for a Lexar flash drive, the utility up-dated the drive's parameters, and the back-up I then ran completed perfectly, with absolutely no errors! I ran the same test on a SanDisk flash drive that had also failed, with the same results.

Whether this action will help with the many different configurations about which I read I cannot say. NAS and remote servers introduce additional devices and potential sources of trouble, but flash drives seem to be involved with the majority of the complaints, so making the drives bootable is at least a simple start. It certainly eliminated the problem in my configuration.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.