4

I am booting directly into the terminal of Linux Mint 17. Now I would like from there to start cinnamon gui. I do that with "startx". However, by doing that I do not have any sound (just "Dummy Output" in output devices) and I get the message telling me that Cinnamon is running in "Software Rendering mode".

Now, if I directly boot into the GUI, then everything works fine. Also if I run "sudo startx" it works fine, but then I'm logged in as root.

EDIT: Here are the outputs for lsmod and service --status-all:

Directly booting into Cinnamon GUI: http://pastebin.com/qWRNVJ6c

Booting to terminal, then startx: http://pastebin.com/BuBDHin3

I am booting into the terminal by adding text into the grub.cfg, see this excerpt of /boot/grub/grub.cfg:

menuentry 'Linux Mint 17 Cinnamon 64-bit, 3.13.0-24-generic (/dev/sda3)' --class ubuntu --class gnu-linux --class gnu --class os {
    recordfail
    gfxmode $linux_gfx_mode
    insmod gzio
    insmod part_msdos
    insmod ext2
    set root='hd0,msdos3'
    if [ x$feature_platform_search_hint = xy ]; then
      search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos3 --hint-efi=hd0,msdos3 --hint-baremetal=ahci0,msdos3  20503a34-3ca8-45dc-9c02-d397c327c85d
    else
      search --no-floppy --fs-uuid --set=root 20503a34-3ca8-45dc-9c02-d397c327c85d
    fi
    linux   /boot/vmlinuz-3.13.0-24-generic root=UUID=20503a34-3ca8-45dc-9c02-d397c327c85d ro quiet text
    initrd  /boot/initrd.img-3.13.0-24-generic
}

The only thing I changed here is adding quiet text instead of quiet splash as it was generated from the Mint installation.

2
  • Please edit and explain i) how exactly you've set up your system to boot to command line? It sounds like the pulseaudio service is not being started; ii) what graphics card you have and which driver for it; iii) what services and drivers are loaded when you boot to GUI and command line? Run lsmod and service --status-all in both conditions and compare the results. That should give us something to go on. Also, please don't cross-post on multiple stack exchange sites. Pick one of the two and delete the other.
    – terdon
    Jun 7 '14 at 13:07
  • @terdon I have updated the question with the infos you asked. If there is something else you need, let me know! thanks
    – Blub
    Jun 7 '14 at 13:38
1

It could be because of the files in /usr/share/xsessions. Try moving cinnamon2d.desktop. I had this problem too but after messing around, it was solved.

1

This is an important question as it involves changes that render old methods obsolete. The method that works for me, at this point, on Mint 17.1 is below.

Command line only login:

Change /etc/default/grub

sudo sed -i 's:quiet splash:quiet text:' /etc/default/grub

sudo update-grub

sudo reboot

Next, start the GUI:

sudo service mdm start

Venerable startx is no longer working and one must start mdm explicitly.

To drop out of the gui back to commandline:

sudo service mdm stop
1

Try adding yourself to the video and audio groups.

In cinnamon, go to "users and groups" in the settings, select your user, click on groups, and add yourself to the audio and video groups. I'm not sure if you need to add yourself to any other groups for any other features to work right.

Then log off and log in again to enact those changes.

https://bbs.archlinux.org/viewtopic.php?id=152824

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.