2

I am currently running into some problems with phpMyAdmin. I set everything up correctly and made sure everything worked. Then later after some developing on some pages I noticed I couldn't execute mysqli_result::fetch_all().

So I did my research and found out I only had to install the package php5-mysqlnd. So I did (apt-get install php5-mysqlnd). The installation did not fail and my PHP script could execute the mysqli_result::fetch_all() method.

However, phpmyadmin doesn't work anymore. It simply can't connect to the MySQL server anymore (all logins fail).

NOTE: every other script still has no problem connecting and logging in into the MySQL server. I also did not change any passwords. Login over the console is also possible.

I couldn't get it to work with the package installed. Then I reinstalled php5-mysql (which uninstalled php5-mysqlnd) and phpmyadmin worked again!

Not having the mysqli_result::fetch_all() method is not a major issue but if it is possible I would like to use it anyways. Simply because it is so convenient for debugging!

I am running a Nginx server and Debian 7.5 3.10.23 system.

  • I'm having the exact same issue. Did you figure it out BrainStone? – Benno Jan 2 '15 at 16:23
  • No. I did not find any solutions. mysql_result::fetch_all() still doesn't work on my system. – BrainStone Jan 2 '15 at 18:55
0

Not sure if this will help you, but I had originally just wget'd phpmyadmin in and set it up manually.

I changed it to using apt-get install phpmyadmin. I also had issues with php5-mysql and php5-mysqlnd not being compatible versions, so I had to remove php5-mysql on all servers and add php5-mysqlnd.

The errors i was getting were From phpmyadmin only. Cannot log in to the MySQL server 2003 Cannot log in to the MySQL server 1043 Cannot log in to the MySQL server

After installing phpmyadmin from apt-get, I basically thought "start from scratch" with configuration.

For me, it was this configuration, that was the difference between being able to login to phpmyadmin and not: $cfg['Servers'][$i]['ssl'] = true;

I removed that option and could login. No idea why!

I would suggest getting a blank template of config.inc.php and adding only the mandatory parameters and seeing what happens...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.