1

I have an Ubuntu 12.04 server that has a successful redmine install on it. I have been using redmine on it for a while, but when I tried to set up the SSL cert using this method, https://www.digitalocean.com/community/articles/how-to-create-a-ssl-certificate-on-apache-for-ubuntu-12-04.

My https:// version of the site just shows my "index of /" instead of the actual site. If I go to the old http:// it still successfully shows the site. The only thing that I've done which isn't standard practice (to the best of my knowledge) is to change my default DocumentRoot in /etc/apache2/sites-available to /var/www/redmine, from the standard /var/www/.

I have made sure that my pages default-ssl document root is also /var/www/redmine (which is where my symbolic link to the actual redmine folder is).

If you need anymore information I'd be happy to post it. Thanks,

  • Can you please paste your configurations? – NeilWang Dec 11 '17 at 9:46
  • Sorry, since this was asked more than 3 years ago, I don't think I still have the server around. I'm sure I figured it out, but I can't remember what fixed it. Also, it's completely my fault that I didn't update this question with an answer. I apologize. – trueCamelType Dec 13 '17 at 19:48
  • Wow, I didn't realize that was an ancient post, lol. How could it appear on the top pages? – NeilWang Dec 14 '17 at 9:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.