3

I'm trying to get Dropbox not to autostart. The manual shows a command line option that should do the trick but it doesn't seem to work here (dropbox autostart n). Running dropbox autostart issues a note warning that it may only work on current Ubuntu distributions.

Questions

  • How can I get it not to start?
  • How should I proceed with the issue?

EDIT

After following some valuable tips, it seems every time I open dropbox, it adds itself to ~/.config/autostart list, which shows in the gnome-session-properties GUI. I wonder if there's a way to stop it. Perhaps not giving the process permissions on that folder?

7
  • I still know almost nothing about systemd and how it initializes stuff. I am interested in learning but hope for a solution sooner than whatever time that might take
    – Rojo
    Jun 4, 2014 at 0:43
  • How did you install dropbox? From my experience it generally runs from gnome-session-properties.
    – slm
    Jun 4, 2014 at 0:47
  • @slm, I didn't konw about gnome-session-properties. I just tried removing it from gnome-session-properties, then starting it manually and then rebooting, and it was back in there.
    – Rojo
    Jun 4, 2014 at 0:56
  • Did you install it via the RPM?
    – slm
    Jun 4, 2014 at 0:56
  • @slm I installed the rpm of the nautilus icon thing from the site, and then the daemon
    – Rojo
    Jun 4, 2014 at 0:56

4 Answers 4

2

In looking through the RPM that's available from the Dropbox website I only see the following content.

$ rpm -qpl nautilus-dropbox-1.6.0-1.fedora.x86_64.rpm |& \
    grep -Ev "/icons/|.icon$|.png$|warning:"
/usr/bin/dropbox
/usr/lib64/nautilus/extensions-2.0/libnautilus-dropbox.so
/usr/lib64/nautilus/extensions-3.0/libnautilus-dropbox.so
/usr/share/applications/dropbox.desktop
/usr/share/man/man1/dropbox.1.gz

We can unroll the RPM to take a peak at the contents like so:

$ mkdir db_unroll
$ cd db_unroll
$ rpm2cpio ../nautilus-dropbox-1.6.0-1.fedora.x86_64.rpm | cpio -idmv

The only file that looks of interest is the .desktop file:

$ more usr/share/applications/dropbox.desktop
[Desktop Entry]
Name=Dropbox
GenericName=File Synchronizer
Comment=Sync your files across computers and to the web
Exec=dropbox start -i
Terminal=false
Type=Application
Icon=dropbox
Categories=Network;FileTransfer;
StartupNotify=false

So how can I stop it from starting?

You could use a modified version of the technique I outline in this other U&L Q&A titled: Update different dropbox instances, which shows how you can run the Dropbox dropboxd daemon for multiple dropbox instances. This same approach will work for a single instance and give you a more sanely behaving Dropbox instance.

Removing the RPM?

If nothing else works, I'd uninstall the RPM and install the binary distro instead. The download page has a section titled: "Install Dropbox via command line".

4
  • That .desktop file is what gets automatically added to ~/.config/autostart every time I open dropbox
    – Rojo
    Jun 4, 2014 at 1:12
  • Nice tip on unrolling rpms with rpm2cpio :)
    – Rojo
    Jun 4, 2014 at 1:14
  • @Rojo - see updates.
    – slm
    Jun 4, 2014 at 1:14
  • @Rojo - I added the removal of the RPM to the A.
    – slm
    Jun 4, 2014 at 2:23
1

There is a lot of different ways to autostart an application on Linux. You should start by checking the most common locations:

  • Gnome Startup Applications GUI (assuming you are using Gnome Shell). If you can't find it in the menus, try running gnome-session-properties from the terminal. Unfortunately this tool is deprecated as of Gnome 3.12, so if you are using 3.12 or newer you should use gnome-tweak-tool.

  • Check the directories /etc/xdg/autostart and ~/.config/autostart for entries related to Dropbox.

  • I believe Dropbox has a setting that you can disable. Click the Dropbox icon, click "Preferences" and uncheck "Start Dropbox on system startup".

If the above methods turn up nothing you should start searching your home directory, then your system for anything that might be starting Dropbox.

  • Start by searching for files related to dropbox: find ~ -name "*dropbox*"
  • Search file contents (might take a long time!): grep -iR dropbox ~
5
  • Thanks. I couldn't find that gnome startups from the GUI, and when i opened it from the termina dropbox was there. Unfortunately that didn't seem to be enough, because it was back there when I rebooted. I see now it is also in ~/.config/autostart. In my home directory there are lots of dropbox related stuff, because I think those are just the package files
    – Rojo
    Jun 4, 2014 at 1:00
  • It seems that ~/.config/autostart is the same as (or included in) the gnome-session-properties list. When I move the file in and out of that folder, it goes in and out of the GUI's list
    – Rojo
    Jun 4, 2014 at 1:04
  • As soon as I try to open dropbox, it puts itself back in that list. Annoying
    – Rojo
    Jun 4, 2014 at 1:05
  • You should try moving the Dropbox file out of the ~/.config/autostart directory. Make sure to also check /etc/xdg/autostart and move all Dropbox files somewhere else. I believe Dropbox has a setting that you can disable. Click the icon, click "Preferences" and uncheck "Start Dropbox on system startup'
    – arnefm
    Jun 4, 2014 at 1:07
  • Yes, the problem seems to be that as soon as I run dropbox it reappears. I edited the question with that data. Perhaps there's a simple way to forbid the process to write on that folder?
    – Rojo
    Jun 4, 2014 at 1:08
1

I also had the same issue: the dropbox.desktop file was automatically added to the autostart folder upon opening Dropbox.

As pointed by @arnefm Dropbox has a "Start Dropbox on system startup" option, on its settings. As soon as I disabled that, the dropbox.desktop file was removed from the autostart folder.

0

On KDE Plasma 5 I have solved this problem by adding the dropbox command to negate autostart after the one to start dropbox on KDE Menu Editor.

So you should search for the Dropbox icon in KDE Menu Editor and edit the command:

dropbox start -i;dropbox autostart n

instead of the standard previous one:

dropbox start -i

If you launch your dropbox through terminal, then the same command to the above also applies.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .