2

Reaver fails to associate with the AP, and guides online say to use aireplay-ng to associate first but none have been very specific with exactly how to associate.

I have been doing this sequence of commands:

sudo airmon-ng start wlan0
sudo airodump-ng mon0 
sudo reaver -i mon0 -b [ap's mac] -vv

I have three routers at home. On one router, using the above commands, it associates, attempt to crack the pin, fails to associate several times in a row, then keeps trying to crack the pin in this cycle. It gets to a grand total of 0.00%. The other two routers always fail to associate altogether.

How to associate with aireplay-ng so I can then use reaver? I made sure my network card is capable of doing monitor mode

  • if the server is susceptible then it will show up with sudo wash -i mon0 -C -s (wash comes with reaver). If not then your ap is not attackble via that method. – rob Jun 2 '14 at 10:40
2

If you see fails to associate several times in a row after 30 seconds or more then reaver is not associating properly with the router. It really needs more code to make it work like aireplay-ng. To get around the problem run aireplay-ng -1 0 mon0 -a 1A:AD:B9:AD:7E:5E whatever your ap no. Is every 30 seconds to re-associate with the router before reaver fails.

Also you need to start reaver with the -c 11 or whatever it is and -A. Do not associate with the AP flag as you are now using aireplay-ng to do that.

Start a watch in another shell like so

. watch -n1  command

.watch -n30  aireplay-ng -1 0 mon0 -a 1A:AD:B9:AD:7E:5E

protected by Community Nov 16 '16 at 19:07

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.