2

After configuring Raspbian linux and a Huawei E303 3G USB stick, I am stuck accessing the machine from the Internet by its public IP address.

Details: The E303 stick was configured to work as an Ethernet device (mode switch worked OK). Linux creates an eth1 device for it and receives an ip address via DHCP from the E303 after adding the device to /etc/network/interfaces. After setting it as the default route, all access from the machine to the Internet works fine - route add default gw 192.168.8.1.

The IP address eth1 receives is 192.168.8.100 - or, if I use a different sub-model of the E303, it is 192.168.1.100. I can tell that the E303 devices are slightly different, because - after mode switching - one of them holds the USB product id 0x014db, the other 0x014dc. Besides the assigned subnets they are not distinct.

Both sticks run a web server and may be accessed without problems, however, there are no configuration option on their network behaviour. They show their own IP address as from the 10.34.X.X subnet (from the device information web page).

Then I registered a dynamic IP address (with no-ip.com) and installed the respective software package. My public IP address is properly registered with no-ip.com (when looking at the hosts listing on their web site) and ping displays the correct, public IP address of my machine. Both, when pinging from the Raspbian and from a different machine in a separate network. Btw, when using the ddclient package, instead, I see the exact same result.

When not using the 3G stick, but plugging in the on-board Ethernet, the machine may be ping'ed, ssh'ed from the local network without problems, and I can get web pages served as well.

My assumptions are that the configuration of the E303 device, routing out, and the dynamic IP address registration are basically OK. But I have no clue how to make the machine visible to the Internet. All connections from the outside time out. The Huawei 3G stick and the telephone provider infrastructure seem to act as intermediate network devices applying NAT without port forwarding to my machine.

1

I had a similar problem. I found out that the the GSM modem ISP blocks all incoming traffic. I read that you can pay the ISP extra to permit incoming traffic. I only wanted to ssh to the RPi over GSM. A reverse SSH tunnel was the solution. I don't know how to solve your problem. But at least I can provide a hint to the cause of it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.