1

I am using CentOS(Linux 2.6.32-431.11.2.el6.x86_64). I am trying to create an Apache2.2.15 web server. Every thing configured very well. My DocumentRoot is the default location i.e. /var/www/html. I am able to create symbolic link which works perfectly. for example I can create a link for the configuration directory i.e. ln -s /etc/httpd/conf/ /var/www/html/conf, and it work perfectly fine. I also made a symbolic link to the home directory but it is not working. When I test my web-server it gave me the following error(403)

Forbidden

You don't have permission to access /test1/home/ on this server.

Apache/2.2.15 (CentOS) Server at my-PC Port 80

the web-server is running as an abc user (abc is a regular user and has home directory access). The permission of the home directory is

drwxr-xr-x.   6 abc abc  4096 May 29 14:47 home

The concerning part of httpd.conf is given below

<Directory "/">
Options Indexes FollowSymLinks Includes ExecCGI
AllowOverride All
Allow from all
</Directory>
<Directory "/var/www/html/">
 Options Indexes FollowSymLinks Includes ExecCGI
 AllowOverride All
 Allow from all
</Directory>

SELINUX is disabled. The error_log tell me the following thing

 [client ########] (13)Permission denied: Can't open directory for index: /var/www/html/test1/home/, referer: http://YYYYYYYYYY/test1/

Can any body suggest me how can I create a symbolic link for the home directory or for the /home/abc/Download directory?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.