2

I'm trying to set up a pulic anonymous user login smb share. Even though my settings are nearly identical to previous successful setups I've made, I still get permission denied.

Here is the share section in my smb.conf file:

[test]
        comment = test
        path = /root/test
        guest ok = yes
        readonly = no
        browsable = yes
        public = yes

I've tailed the following files and seen nothing when trying to access the share:

  1. /var/log/samba/log.smbd
  2. /var/log/samba/log.nmbd
  3. /var/log/samba/log.192.168.1.2
  • I'm willing to say that is not samba the problem but your firewall. – Braiam May 28 '14 at 15:12
  • It's a turnkey linux LAMP stack installed on a VM. iptables is disabled. Also, smb://192.168.1.12 is browsable and I can see the share, I just can't log into it. – Tom Klino May 28 '14 at 15:33
  • Check the permissions for the original setup vs the new setup. Even though you have guest ok = yes for the test dir, the files may be restricted to specific users or groups (aka root) – Jeight May 28 '14 at 20:29
  • After it failed the first time, I changed the permissions to 777 recursively but that didn't help. Also, the smbd is run by root (as this is a turnkey machine) – Tom Klino May 28 '14 at 21:33
1

Finally found the issue.

Although the entire file structures under test directory was with 777 permissions, the directory containing it was with 700. changed it to 755 and it is now working okay.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.