13

Ok, I know that there is https://askubuntu.com/questions/455511/dual-boot-ubuntu-14-04-and-windows-7-on-fakeraid-installation-error-question-m#new-answer?newreg=f2b8bde40c8947f8ac8e3cedec0d1964 and that that post has some answers for me, but I don't know if it exactly matches what I need help with. I am running on a RAID 0, not sure if it's a Fake RAID or not.

Just to start I am running an Alienware (Dell) M17xR3. It came with Windows 7. Have a RAID 0 array, I think it's a "Fake" RAID, but I know I also have a hardware RAID controller. Previously partitioned and had Ubuntu 13.04 installed, had no issue installing it, creating the partition and installing GRUB. I have since upgraded to Windows 8.1 Pro, lost GRUB during the installation, but from the HDD partition size of Windows, I knew my Linux partition was still there. Should have just reinstalled GRUB, but instead tried reformatting the Linux partition and doing a clean install of Ubuntu 14.04 x64 and also tried Mint 16 x64 Cinnamon. Exact same installer, and exact same error message, happened after the custom partition section, got just ??????. I don't know if Windows 8 created an EFI/UEFI install, but I'm pretty sure Windows 7 didn't have it.

This is the link to the thread I posted it to: http://forums.linuxmint.com/viewtopic.php?f=46&t=164950&e=0

Per that thread it was asked for some terminal outputs to be posted so here they are:

"sudo parted -l" output:

Error: Can't have a partition outside the disk!                           

Error: /dev/sdb: unrecognised disk label                                  

Model: Linux device-mapper (linear) (dm)
Disk /dev/mapper/isw_dcigjjhddj_M17X_RAID0p6: 212GB
Sector size (logical/physical): 512B/512B
Partition Table: loop

Number  Start  End    Size   File system  Flags
 1      0.00B  212GB  212GB  ext4


Error: /dev/mapper/isw_dcigjjhddj_M17X_RAID0p5: unrecognised disk label   

Error: Can't have a partition outside the disk!                           

Model: Linux device-mapper (linear) (dm)
Disk /dev/mapper/isw_dcigjjhddj_M17X_RAID0p3: 758GB
Sector size (logical/physical): 512B/512B
Partition Table: loop

Number  Start  End    Size   File system  Flags
 1      0.00B  758GB  758GB  ntfs


Model: Linux device-mapper (linear) (dm)
Disk /dev/mapper/isw_dcigjjhddj_M17X_RAID0p2: 14.2GB
Sector size (logical/physical): 512B/512B
Partition Table: loop

Number  Start  End     Size    File system  Flags
 1      0.00B  14.2GB  14.2GB  ntfs


Model: Linux device-mapper (linear) (dm)
Disk /dev/mapper/isw_dcigjjhddj_M17X_RAID0p1: 41.1MB
Sector size (logical/physical): 512B/512B
Partition Table: loop

Number  Start  End     Size    File system  Flags
 1      0.00B  41.1MB  41.1MB  fat16


Model: Linux device-mapper (striped) (dm)
Disk /dev/mapper/isw_dcigjjhddj_M17X_RAID0: 1000GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End     Size    Type      File system  Flags
 1      32.3kB  41.1MB  41.1MB  primary   fat16        diag
 2      41.9MB  14.2GB  14.2GB  primary   ntfs         boot
 3      14.2GB  773GB   758GB   primary   ntfs
 4      773GB   1000GB  228GB   extended               lba
 6      773GB   984GB   212GB   logical   ext4
 5      984GB   1000GB  15.7GB  logical


Warning: Unable to open /dev/sr0 read-write (Read-only file system).  /dev/sr0
has been opened read-only.
Model: PLDS DVD+-RW DL-8A4SH (scsi)
Disk /dev/sr0: 1252MB
Sector size (logical/physical): 2048B/2048B
Partition Table: mac

Number  Start  End     Size    File system  Name   Flags
 1      8192B  24.6kB  16.4kB               Apple
 2      171MB  180MB   9306kB               EFI

"sudo blkid" output:

/dev/loop0: TYPE="squashfs" 
/dev/sda: TYPE="isw_raid_member" 
/dev/sr0: LABEL="Linux Mint 16 Cinnamon 64-bit" TYPE="iso9660" 
/dev/sdb: TYPE="isw_raid_member" 
/dev/mapper/isw_dcigjjhddj_M17X_RAID0p1: SEC_TYPE="msdos" LABEL="DellUtility"  UUID="5450-4444" TYPE="vfat" 
/dev/mapper/isw_dcigjjhddj_M17X_RAID0p2: LABEL="RECOVERY" UUID="3C9A4EA39A4E5A12"     TYPE="ntfs" 
/dev/mapper/isw_dcigjjhddj_M17X_RAID0p3: UUID="C614C2E714C2D997" TYPE="ntfs" 
/dev/mapper/isw_dcigjjhddj_M17X_RAID0p6: UUID="e39970ed-c278-4135-a8fb-3806cd62835b" TYPE="ext4" 

"lsblk" output:

NAME                                   MAJ:MIN RM   SIZE RO TYPE   MOUNTPOINT
sda                                      8:0    0 465.8G  0 disk   
└─isw_dcigjjhddj_M17X_RAID0 (dm-0)     252:0    0 931.5G  0 dmraid 
  ├─isw_dcigjjhddj_M17X_RAID0p1 (dm-1) 252:1    0  39.2M  0 part   
  ├─isw_dcigjjhddj_M17X_RAID0p2 (dm-2) 252:2    0  13.2G  0 part   
  ├─isw_dcigjjhddj_M17X_RAID0p3 (dm-3) 252:3    0 706.4G  0 part   
  ├─isw_dcigjjhddj_M17X_RAID0p4 (dm-4) 252:4    0     1K  0 part   
  ├─isw_dcigjjhddj_M17X_RAID0p5 (dm-5) 252:5    0  14.6G  0 part   
  └─isw_dcigjjhddj_M17X_RAID0p6 (dm-6) 252:6    0 197.3G  0 part   
sdb                                      8:16   0 465.8G  0 disk   
└─isw_dcigjjhddj_M17X_RAID0 (dm-0)     252:0    0 931.5G  0 dmraid 
  ├─isw_dcigjjhddj_M17X_RAID0p1 (dm-1) 252:1    0  39.2M  0 part   
  ├─isw_dcigjjhddj_M17X_RAID0p2 (dm-2) 252:2    0  13.2G  0 part   
  ├─isw_dcigjjhddj_M17X_RAID0p3 (dm-3) 252:3    0 706.4G  0 part   
  ├─isw_dcigjjhddj_M17X_RAID0p4 (dm-4) 252:4    0     1K  0 part   
  ├─isw_dcigjjhddj_M17X_RAID0p5 (dm-5) 252:5    0  14.6G  0 part   
  └─isw_dcigjjhddj_M17X_RAID0p6 (dm-6) 252:6    0 197.3G  0 part   
sr0                                     11:0    1   1.2G  0 rom    /cdrom
loop0                                    7:0    0   1.1G  1 loop   /rofs

"inxi -b" output:

System:    Host: mint Kernel: 3.11.0-12-generic x86_64 (64 bit) Desktop: Gnome Distro: Linux Mint 16 Petra
Machine:   Mobo: Alienware model: M17xR3 version: A08 Bios: Alienware version: A08 date: 07/29/2011
CPU:       Quad core Intel Core i7-2670QM CPU (-HT-MCP-) clocked at 2192.734 MHz 
Graphics:  Card-1: Intel 2nd Generation Core Processor Family Integrated Graphics Controller 
           Card-2: NVIDIA GF116M [GeForce GT 560M] 
           X.Org: 1.14.3 drivers: (unloaded: fbdev,vesa) FAILED: nouveau,intel Resolution: 1920x1080@60.0hz 
           GLX Renderer: Mesa DRI Intel Sandybridge Mobile GLX Version: 3.0 Mesa 9.2.1
Network:   Card-1: Qualcomm Atheros AR8151 v2.0 Gigabit Ethernet driver: atl1c 
           Card-2: Qualcomm Atheros AR93xx Wireless Network Adapter driver: ath9k 
Drives:    HDD Total Size: 1000.2GB (-)
Info:      Processes: 211 Uptime: 20 min Memory: 524.9/7932.9MB Client: Shell inxi: 1.8.4 
2
  • You are trying to install grub in the wrong place. Try to install it in the Ubuntu partition.
    – user124532
    Sep 10, 2015 at 16:53
  • I installed EasyBCD for a similar dual-boot configuration a few years back and I haven't had any issues with it.
    – bootbeast
    Nov 18, 2017 at 1:43

2 Answers 2

0

You appear to be assembling two 465.8 physical volumes into a raid0 (stripe) which should yield a roughly 931.6 (minus overhead) sized logical partition.

You then have (apparently according to your lsblk output) partitions totaling 1863.039201G

I may be wrong, but it appears you have multiple issues here:

  1. You're trying to use roughly twice your total available disk space (or possibly 4x if lsblk is reporting the partition sizes and not the logical disk sizes)
  2. You appear to be using the entire disk for (a very strange set of partitions) which are built using linux software raid and thus won't be visible when you boot Windows.

As a result, parted can't make heads or tails of what you're trying to do.

If you want to dual-boot, you probably need to create two software raid partitions on each disk (one using Windows software raid, one using Linux) and then create logical volumes as needed within those.

You also need to constrain the sum of all your partitions to fit within the available size of your disks.

0

The above information isn't very helpful in figuring out the issue. So to be frank, I just skimmed it. And most of it isn't really relevant to the issue at hand to be honest. Ill tell you what I have learned doing this for years, and just cover the biggest things people miss. Its actually very complex to get it to work like you want, and even I struggle to keep it stably dual booting.

The Biggest Landmine

But what you want to do is to look at a few things.

The biggest issue is that windows will always try and seize control of the boot process. It "repairs" it whenever it doesn't boot first.

3 menus in Windows where the boot settings are stored are in the System Properties dialog (Win + Pause/Break) and startup, the msconfig dialog. (Win + r) and type msconfig

You essentially need to make something else grab control of the BIOS before the 'Windows Boot Manager' does. This can be quite difficult. The Windows Boot Manager is designed to make sure most peoples computers (average Joe) always boot into Windows, so it acts a bit like a worm. Well need another EFI boot partition, and to set that as higher priority in BIOS. That boot partition is probably though not necessarily separate from the /boot/ ('partition') in Linux.

That's where Grub, rEFInd, and others come into play. I think Clover is another. I cant recall

I will skim past BCDEDIT and MSCONFIG, mostly because I cant remember what if anything I needed to change there. But it helps to know where to look if you need something from Windows.

Fast (Hybrid) Boot

You must disable fast boot in windows.

You must do this because otherwise the partition will be marked 'dirty' and you cant open other partitions on the drive except the dirty one. You can dump the 'dirty' bit and ignore it, but Ill leave that out as well.

Google how to do that, but here is the fastest way- in a Admin terminal (Win + R, type cmd, then hit [Ctrl]+[Shift]+[Enter] which means run command as admin.)

Doc for Powercfg

powercfg /L

You need the long number with the * at the end. Your current one.

then run the following:

powercfg /Q c9595e0a-3307-424c-837a-07b70f3f6922 SUB_SLEEP HYBRIDSLEEP
#Where the string of numbers is yours.  The commands are shorthand for other long GUID numbers, see powercfg /ALIASES

powercfg /SETACVALUEINDEX c9595e0a-3307-424c-837a-07b70f3f6922 SUB_SLEEP HYBRIDSLEEP 0
powercfg /SETDCVALUEINDEX c9595e0a-3307-424c-837a-07b70f3f6922 SUB_SLEEP HYBRIDSLEEP 0

This is actually the wonderfully simple: powercfg /SETACVALUEINDEX c9595e0a-3307-424c-837a-07b70f3f6922 238c9fa8-0aad-41ed-83f4-97be242c8f20 94ac6d29-73ce-41a6-809f-6363ba21b47e 0x00000000

Which is typical Microsoft fashion 'Why make something simple when you can make it much much more complicated. There is a GUI way to do it but its also absurdly hard to find. Power Options-> Advanced Settings-> Choose what the power buttons do -> and somewhere there. I can actually never find it, it depends on how you get to it, e.g. from the start menu it doesn't show.

Next alter the boot profile of windows if needed.

Doc for BCDEDIT Finally, there is BCDEDIT - from the same admin cmd prompt.

First export a copy to a file as a backup.

BCDEDIT /export C:\bcdbackup

See Also Here at the bottom

Annoyingly, they don't help dual boot windows with Linux, just Windows with Windows.

The Linux side

Then you need to create a new Partition of about 100mb. Do this in Linux.

Most of the EFI work is best done in Linux. That too is well documented there.

rEFInd boot manager

I like REFInd as a boot manager, as it served me well for years. Though frequently Windows will take it over again.

There is pretty good documentation over at The rEFInd site. But pay particular attention to This topic - Keeping rEFInd Booting that covers recovering from a boot coup. and This

Install rEFInd from the pacakage manager. And Run refind-makedefault. As I am doing this bit from memory its best you read the documentation below.

I have just tried to cover the landmines and roadblocks, and point you to where to find information. The main issue is preventing windows.

That may be simpler.


Boot Flags

As for the mess of the partitions above, I cant comment because I have a real mess of partitions on my drive. But you need 3 for Windows (boot, recovery, and OS) and then at least 2 for linux (and possibly many more) You need a small boot partition for Linux/Boot Manager that will let you step into Linux.

Your Boot partition must have the EFI Boot flag set.

See here


Secure Boot

Secure boot can be a big pain. Not all linux distros are properly setup to be considered "secure". Even when they are they wont always work. Try disabling this in BIOS and it might boot right away, but then Windows usually wont boot.

Sometimes I swear the BIOS'es treat Secure Boot as a Alias for "Windows". In Windows 10 you can sometimes boot into it with Secure Boot disabled in BIOS, but often not. So what ends up happening is that with Secure Boot disabled, the computer boots linux because its the only option, and with it enabled it boots windows. There are ways to set up the Linux distro to be "secure" - and also the "boot manager" but its complicated and outside the scope.

This is especially an issue in more recent versions of Win 10 and definitely Windows 11. Where it REQUIRES Secure Boot to be enabled, and the bit that makes it "Secure" is that ONLY windows can boot, nothing else that might have nefarious, or even desired effects. Like a boot manager.


Alternatives to What You're Attempting

  • It is always difficult to keep it dual booting.
    Depending on what your goals are WSL2 built into windows works great for any Linux CLI stuff, and I use that more and more these days.

  • Alternatively, if you just want to try it out, just put the entire thing on a thumb drive, and use that for a while before you decide you want to go through the headache of dual booting.

  • You can also have another option by creating boot partition on a thumb drive, and set the boot priority to the USB over disk. Then have that partition book the Linux partition. So then its like a physical switch, if its in, it'll boot from the USB, which will point it to the initramfs on disk to load.

  • Or put it on an old machine and remote into it. Thats generally what I do these days, I have VMs running on a server, or RasPi and just SSH or VNC (or even RPC) into them. Those have their own set of instructions but are probably much lower friction.

  • Finally, the Windows Hyper-V system can be a great option, also the other two VirtualBox, and ... the other I cant recall. The performance hit can be negligible.


I know I havent told you what exactly to do, but maybe if you identify one of the above is stopping you- youll make some progress.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.