3

I have installed CentOS 6.5 on a Dell Insperion with an Intel chip. I first noticed that my microphone is not working on Skype on CentOS although it was working fine with Windows 7 on the same box. The speakers work fine on both operating systems. I did the following test.

arecord -vv -d 10 test.wav
aplay -vv test.wav

and did not get any sound played back. I went to System:Preferences:Sound to get the Sound Preferences dialog. I went to the Input tab and "Microphone" was selected as the connector. I turned the input volume up to maximum and spoke into the microphone but the "Input level" boxes all remained a light grey like it was disabled. The only option for "Choose a device for sound input" is "Internal Audio Analog Stereo".

  • CentOS 6.5 has a very outdated kernel which means the mic might not work because your kernel sound drivers don't talk to your hardware properly. I can't say for sure that's the case but it's very likely. – Artem S. Tashkinov Jun 29 at 20:08
  • Thank you for the reply. I now use CentOS 7.8 and have no problems with the microphone or speakers. Thanks, – OtagoHarbour Jun 29 at 22:07
0

Try install pavucontrol.

yum install pavucontrol

After installation, from menu open PulseAudio Volume Control

Here the input devices will be detected. The built-in volume control seem to face some problem. It worked for me.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.