0

I am using Arch linux (fully updated). I have been trying to get my BSNL 3G usb modem to work to no avail for the past couple of hours. I have already installed modeswitch, wvdial, modem manager, gnome-ppp, etc but whatever I try throws up some error or the other. When I try wvdial now, this is what I get:

--> WvDial: Internet dialer version 1.61
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 +FCLASS=0
ATQ0 V1 E1 +FCLASS=0
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ERROR
--> Bad init string.

When I run modeswitch to maybe change the usage mode of the modem, I get this error :

[venkat@hal9000 ~]$ sudo usb_modeswitch -v 19d2 -p 2003 -u 2
Look for default devices ...
   product ID matched
Get the current device configuration ...
 Found devices in default mode (1)
Access device 008 on bus 001
Current configuration number is 1
Use interface number 0

USB description data (for identification)
-------------------------
Manufacturer: ZTE,Incorporated
     Product: ZTE WCDMA Technologies MSM
  Serial No.: MF1800ZTED010000
-------------------------
Change configuration to 2 ...
 Device is busy, try to detach kernel driver
Looking for active driver ...
 No active driver found. Detached before or never attached
 Device is busy, try to detach kernel driver
Looking for active driver ...
 No active driver found. Detached before or never attached
 Device is busy, try to detach kernel driver
Looking for active driver ...
 No active driver found. Detached before or never attached
 Device is busy, try to detach kernel driver
Looking for active driver ...
 No active driver found. Detached before or never attached
 Changing the configuration failed (error -6). Try to continue
-> Run lsusb to note any changes. Bye!

I need some quick help setting this up guys as I will be travelling in a few days. Also, this is my wvdial.conf file :

[Dialer Defaults]
Init1 = ATZ
Init2 = ATQ0 V1 E1 +FCLASS=0
Init3 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Password = '9445143977'
Phone = *99#
Modem Type = Analog Modem
Stupid Mode = 1
Baud = 9600
Dial Command = ATDT
Modem = /dev/ttyUSB1
ISDN = 0
Username = '9445143977'
Auto Reconnect = off

1 Answer 1

0

You can use networkmanager and networkmanager-applet

Networkmanager: https://wiki.archlinux.org/index.php/NetworkManager

https://www.archlinux.org/packages/extra/i686/networkmanager/

Networkmanagerapplet: https://www.archlinux.org/packages/extra/i686/network-manager-applet/

It's very easy! Try it out!

You must log in to answer this question.