8

Running the most recent Lubuntu 14.04 as a live OS inside virtual box works without any problemes at 1024 x 768 pixels screen resolution. But when I install it, Lubuntu has a low resolution of 620 x 480 or something little like this.

If I install VBoxGuestAdditions it is possible to make the screen bigger. But why does this not work out-of-the-box like the live cd? Any ideas how (or which files) to copy the configuration from the live cd?

4 Answers 4

8

Lubuntu 14.04:

  1. Start -> Preferences -> Additional Drivers
  2. Wait for the additional drivers to be located
  3. Check the circle labeled "Using x86 virtualization solution - guest addition module source for dkms..."
  4. Click Apply Changes
  5. Wait for the changes to be applied
  6. Click Close.
  7. Restart.

You may need to restart twice. You should now be able to change resolutions to higher than 640x480 in Preferences -> Monitor Settings.

2
  • With this solution now I have 800x600. Do you know if it is possible a little bit more? Commented Feb 17, 2015 at 6:42
  • Same with me I now have 800x600. But my host screen size is 1280x800. How do I configure it to use the full screen? Commented May 1, 2015 at 14:15
2

In VirtualBox it does not work out-of-the-box because the default video driver does not support high resolutions. While the virtual graphics card which VirtualBox emulates for any guest operating system provides all the basic features, the custom video drivers that are installed with the Guest Additions provide you with extra high and non-standard video modes as well as accelerated video performance.

The module which loads the driver from VirtualBoxGuest additions is called vboxvideo. You can see information about it by running:

$ modinfo vboxvideo
filename:       /lib/modules/3.13.0-24-generic/misc/vboxvideo.ko
license:        GPL and additional rights
version:        4.3.10
description:    Oracle VM VirtualBox Graphics Card
author:         Oracle Corporation
srcversion:     50D5633D4C20243DD7BDE20
alias:          pci:v000080EEd0000BEEFsv*sd*bc*sc*i*
depends:        drm
vermagic:       3.13.0-24-generic SMP mod_unload modversions

It won't work simply by copying any driver from the live cd because VirtualBox hardware is virtualized not real. The live CD detects you're real hardware and so it can load the proper drivers. If you want this to be done automatically when you run the live CD you need to remaster the iso image and insert the drivers.

2
$ sudo leafpad /etc/xdg/lxsession/LXDE/autostart

add:

xrandr --auto --primary --mode 1024x768

And reboot.

2
  • The path of the configuration file has changed to /etc/xdg/lxsession/Lubuntu/autostart in Lubuntu 14.4
    – orkoden
    Commented Aug 20, 2014 at 11:20
  • This didn't fix the problem for me. Preferences->Monitor Settings still only shows Auto & 640x480. Selecting Auto check and selects 640x480. :-( Commented May 1, 2015 at 14:11
0

Virtualization is not meant to be 1:1 it can never replace a hypervisor because part of the problem is that you cannot install a graphics driver. So the video output regardless what you select will always be limited to the draw space that virtualization allows.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .