Dropbox icon was between Mint update manager and keyboard icon, but it was disappeared like the image below.

enter image description here

Dropbox is still running, how can I make it appear in task tray again without logging out? I'm using LinuxMint 16 Cinnamon.

  • have you done something before it happened? – MickyInTheSky May 19 '14 at 8:51
  • As far as I can remember I was installing ruby by using rbenv and deleting some file from Dropbox. When I noticed the Dropbox icon have been already disappeared. – ironsand May 19 '14 at 10:48
  • 1
    Uhm... I'd advise you to reinstall dropbox packages from synaptic because it is a strange behaviour. Take a look also to this post – MickyInTheSky May 19 '14 at 10:55
  • This is a issue with Cinnamon, I have the same problem with a variety of apps that I run, Pidgin, ClipIt, and Shutter to name a few. – slm Sep 15 '14 at 15:10

For what it's worth: I had the same problem, running Mint 17 with Cinnamon. Dropbox would be running and syncing fine, but no icon. All I had to do to fix is right click on the "task bar" (or whatever the kids are calling it these days), go to "Add applets to the panel", and in the Applets dialog click the "Restore to default" button. Apparently one of the gadgets I had installed (wish I could tell you what it was exactly) had somehow clobbered both the Dropbox icon and the little Mint Update shield. All sorted now.

| improve this answer | |
  • 1
    This fixed it for me. I had to stop dropbox ( kill $(ps -C dropbox -o pid --no-header) ) and then started it from the cinnamon menu after I had reset the panel to defaults and the icon appeared. – jetole Aug 24 '15 at 16:06
  • Ha-ha, the part about kids is very funny. I'm sorry for the "unprofessional" comment, but i just couldn't help myself with it. Also the answer indeed helps with the dropbox icon. – mykolaj Nov 22 '15 at 21:37
  • holy cow this fixed my tray issues on Arch! Everything came back..! – Tommy Mar 28 '16 at 2:17

Are you sure the Dropbox process is still running, and still responsive? Run dropbox status. If it is, just run dropbox stop and dropbox start and that should bring the icon back.

| improve this answer | |
  • This is by far the best solution for me. Works great on Cinnamon 2.4 too – Antony Dec 15 '14 at 13:12
  • Well, this solution is not perfect. For some odd reason, on Cinnamon 2.8.6, it does not work: dropbox stop gives Dropbox isn't responding! and dropbox start reports Dropbox isn't responding! and Dropbox is already running! without any changes in the tray. The -i flag does not help either. – Andreï Kostyrka Jan 28 '16 at 18:24
  • @AndreïKostyrka That has nothing to do with Cinnamon. Cinnamon is just a desktop environment/UI. You probably need to upgrade your installation of Dropbox. Try killing the dropbox process, then removing ~/.dropbox-dist, and then running dropbox -i. That should cause it to download the latest version of the daemon. – blujay Feb 4 '16 at 20:18
  • @blujay I had tried that before posting that comment. After the fresh dæmon is installed, for 10 minutes everything works fine, and then, the tray icon becomes non-responsive again. More that that... I reinstalled LMDE 2 without backing up the hidden configuration folders in /home/myname, updated all the packages, installed the newest Dropbox... and the problem persisted even on a clean and up-to-date system! I guess that some Cinnamon tray-related package might break the way the tray icon interacts with the mouse. Happily configuring Dropbox from command line for two weeks now... – Andreï Kostyrka Feb 4 '16 at 22:33
  • @AndreïKostyrka Are you sure that it's only the tray icon that doesn't work? Perhaps there's some corruption in the Dropbox database. You could try deleting ~/.dropbox as well. And you could post here what version of Dropbox you have. ;) Anyway, if you end up having to report a bug to Dropbox...good luck. They haven't even bothered to respond to reports of bad memory leaks (e.g. using 1-2 GB of memory after a week or two of uptime) from multiple users for months now. – blujay Feb 6 '16 at 4:52

I was encountering a similar issue with a variety of apps that I use, mainly, Pidgin, Shutter, and ClipIt. The issue would typically arise when I had to restart Cinnamon due to it hanging or consuming too much memory. I would typically do this to restart Cinnamon.

$ pkill -HUP -f "cinnamon --replace"

I found a solution that seems to work, with respect to keeping the icons in the system tray from becoming blank and unclickable. Under the Panel Settings dialog you can enable it so that Cinnamon can scal panel text and icons according to the panel's height.


More on killing the apps

My prior work around which mostly worked involved killing the apps that were having this issue in the system tray, Pidgin, ClipIt, and Shutter. I would typically do this after HUP killing Cinnamon.

$ pkill pidgin; pkill clipit, pkill shutter

And then restart them like so:

$ pidgin & clipit & shutter & disown -a

This would 90% of the time bring back Shutter and ClipIt, but it never would work for Pidgin. The workaround above seems to have resolved the issue.


| improve this answer | |

There is a workaround here: https://www.dropboxforum.com/hc/en-us/community/posts/204585553-Systray-menu-Cinnamon


| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.