4

I have installed Mint linux 16 with cinnamon, and I have an ASUS N550JV CN270H including a multitouchpad I tried different things to tweak multitouch gestures, namely:

Using support in xorg.conf as suggested here: http://community.linuxmint.com/tutorial/view/1361

I also used ginn, but it did not satisfy my needs; that is, I could not get it working. So I removed the xorg.conf file again, and purged ginn. Afterwards I tried easystroke, but I was not able to configure gestures which did not involve modifiers or clicks; maybe that is just me. So I removed it and now I use touchegg.

Touchegg is exactly what I am looking for, and it can detect up to 4 fingers (maybe even more, I did not test). However, it does not catch the 2 finger events. I simply compiled the touchegg source and ran the file in a console, which almost works fine. I guess the 2 finger events are caught by gnome (or cinnamon) and not passed trough (i.e. propagation is stopped). I think so is because gnome-control-center has the option to detect two finger gestures for simply scrolling:

multitouch in gnome-control-center

I disabled scrolling here, to allow gnome to pass these events without race condition consequences. Unfortunately that does not seem to work.

I am able to use two finger scrolling via the gnome-control-center interface and configure the rest via touchegg, however I would prefer handling all gestures via touchegg, in order to have a bit more functionality. Would this be possible? Can I get touchegg to receive all touch event? Is there a way to see what the 'event propagation stack' of these touch events is?

1

Did you try configuring synaptics? Set the values you want to use to 0 and that should enable touchegg to control them. For instance,

synclient HorizTwoFingerScroll=0
synclient VertTwoFingerScroll=0

synclient alone echoes a list of available parameters.

source

0

Near the bottom of this post: https://wdullaer.com/blog/2015/10/08/multitouch-trackpad-gestures-with-touchegg/

The author gives a list of synaptics configuration settings that should disable all two finger gestures. This might work for your scenario.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.