2

I'm using Lubuntu 11.10 on a Sony Vaio.

After I connected my laptop on a projector for my talk I'm having a problem with the size of one window.

As you can see below (Fig. 1) the Mathematica window title bar is outside the screen and so I can not resize it.

If I right button click on the program button (on the panel) and choose Maximize, OK, the window is visible. (Fig. 2)

But when I restore its size, the position goes back to outside.

Any help?

enter image description here

enter image description here

3

I'm not 100% sure why Mathematica is launching with the oversized window.

However when I have windows that go off screen and I want to move them so that you can see their title bars you can hold down the ALT key and then put the mouse anywhere on the window you want to move, and then hold down the left mouse button and drag the window in place so that you can see the title bar.

Example

                 ss #1

NOTE: In the above screenshot you can see that when you press the ALT key that the cursor changes to a hand (in GNOME). When this happens you can then move the window as if you had selected it by its title bar.

Can I change the size?

I found this question asked on the Mathematica SE site titled: Opening new notebooks with a non-default window size which mentions that you can change the size of the notebooks when they open up as follows:

excerpt

The default window size can be controlled from two different places. The first is the Global $FrontEnd WindowSize, set through the Option InspectorGlobal Preferences or with:

SetOptions[$FrontEnd, WindowSize -> {300, 900}]

The second is the WindowSize of the style sheet itself. If it is defined, the WindowSize of the style sheet will overrule the setting above. You set the style sheet size through the Option InspectorSelected Notebook or by evaluating this inside the style sheet itself:

SetOptions[EvaluationNotebook[], WindowSize -> {300, 900}]
6
  • Owww I can not believe. So simple solution. Thanks so much. You helped a lot.
    – Sigur
    May 16 '14 at 1:17
  • In my LXDE, no hand icon, but I can move the window simply holding Alt and dragging it.
    – Sigur
    May 16 '14 at 1:18
  • 1
    @Sigur - Glad it worked. Also I found another method that might work for actually changing the def. sizes too. See updates.
    – slm
    May 16 '14 at 1:24
  • Where should I type SetOptions[$FrontEnd, WindowSize -> {300, 900}] or the other command? I typed it on my notebook opened file but nothing happens.
    – Sigur
    May 16 '14 at 1:35
  • 1
    May God bless you, sir! I was struggling with everything being blown out of proportion when playing with themes!
    – Kyle H
    Dec 12 '20 at 22:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.