On my configuration, autojump autocomplete feature does not seem to work. To be clear, autojump works properly, only the autocomplete feature fails to work.

When I press the <TAB> key, the autocompletion menu is not displayed but the directory name I typed is partially enclosed in quotes.

Here is what happens. Note that after typing liba, I pressed the <TAB> key multiple times. I would have expected autojump to cycle through /tmp/liba1 and /tmp/liba2. Also not that /tmp/liba2 only appears after I pressed the<ENTER> key.

Autojump autocompletion attempt

I am using :

  • Konsole 2.12.4 (KDE 4.12.4) (but I have the same issue with xterm)
  • Liquidprompt
  • Bash 4.3.11
  • Autojump 21.6.9

Here is the bottom of my .bashrc file :

# Alias definitions.
# You may want to put all your additions into a separate file like
# ~/.bash_aliases, instead of adding them here directly.
# See /usr/share/doc/bash-doc/examples in the bash-doc package.

if [ -f ~/.bash_aliases ]; then
    . ~/.bash_aliases

# enable programmable completion features (you don't need to enable
# this, if it's already enabled in /etc/bash.bashrc and /etc/profile
# sources /etc/bash.bashrc).
if ! shopt -oq posix; then
  if [ -f /usr/share/bash-completion/bash_completion ]; then
    . /usr/share/bash-completion/bash_completion
  elif [ -f /etc/bash_completion ]; then
    . /etc/bash_completion

# Liquidprompt
source ~/.liquidprompt/liquidprompt
# Autojump
. /usr/share/autojump/autojump.bash

Apparently this is an autojump bug : Bad bash tab completion #228. Manually installing the latest version of autojump solves the issue.

git clone git://github.com/joelthelion/autojump.git
cd autojump
vim ~/.bashrc
# Add line [[ -s /home/fabien/.autojump/etc/profile.d/autojump.sh ]] && 
# source /home/fabien/.autojump/etc/profile.d/autojump.sh

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.