0

Successfully installed Solaris 10 sparc on KVM. However when I restarted the VM it doesn't go to login screen but just constantly reboots. I've read different documents link1 link2 link3 but none of their solutions helped. I used Ubuntu 12.04 and installed Solaris using Virt-Manager. I updated qemu-kvm to the latest version (2.0) as the one installed in Ubuntu is quite old. I have the following configuration below in setting up Solaris in virt-manager, if this helps.

ISO - sol-10-u11-ga-sparc-dvd.iso


Memory: 2GB
Processors: 1 
Hard Disk: raw, 
cache=writeback, IDE
Network: E1000
Sound: ac97
OS Type: Other OS types (other) choose Solaris 10
Boot order: Disk 'ide0', CD-ROM
Tablet for Pointer: No
Use local time for RTC: Yes
2
  • Does it always reboot at the same point in the boot process? What point is that? Can you see anything on the console or access any logs? May 14, 2014 at 22:47
  • yes, it lets me choose to boot either to solaris or a failsafe option and after a few seconds when i chose one of those options it will go back to that point again.
    – dimas
    May 14, 2014 at 23:19

2 Answers 2

2

I had a similar problem with Solaris x86 after upgrading QEMU from 1.5.3 to 2.0.0. A quick git bisect session on QEMU source repository proved this commit to be the culprit:

target-i386: Set model=6 on qemu64 & qemu32 CPU models

Apparently Solaris 10 doesn't like this a lot (Solaris 11 works fine).

While this probably doesn't help your case a lot, you might want to try:

  • doing a QEMU git bisect for your issue,
  • downgrading QEMU to an older branch (unless you have your reasons to use version 2.0).
2
  • Are you really running a Solaris kernel on SPARC ? If true, how is this "target-i386" issue related to the SPARC architecture ?
    – jlliagre
    Jul 7, 2014 at 13:50
  • @jlliagre Good point, thanks. I've missed the SPARC part. I've updated my answer accordingly.
    – Kempniu
    Jul 7, 2014 at 14:32
0

Solaris10 X86 works fine on new Qemu-3.1.0 and libvirt-4.9 I have tried to "backport" from VirtualBox to qemu but fail, a fresh install works well.

With the sparc version I have only fails..simply the boot process won't start.

I have installed from DVD and using the serial console,fs is ufs(not tried zfs but I think will work)

Remind: On some cpu may be not work fine and panic

If someone need,this is the xml dump,only edit the mac address with correct values,the disk image path and wathever you want.

<domain type='kvm' id='12'>
  <name>solaris10</name>
  <uuid>c76c491e-c264-4939-8333-835dae48405f</uuid>
  <title>solaris10</title>
  <description>Virtual machine solaris10 with serial</description>
  <memory unit='KiB'>3145728</memory>
  <currentMemory unit='KiB'>3145728</currentMemory>
  <vcpu placement='static'>1</vcpu>
  <resource>
    <partition>/machine</partition>
  </resource>
  <os>
    <type arch='x86_64' machine='pc'>hvm</type>
    <bootmenu enable='yes'/>
  </os>
  <features>
    <acpi/>
  </features>
  <cpu mode='host-passthrough' check='partial'/>
  <clock offset='localtime'/>
  <on_poweroff>destroy</on_poweroff>
  <on_reboot>restart</on_reboot>
  <on_crash>destroy</on_crash>
  <devices>
    <emulator>/usr/bin/qemu-system-x86_64</emulator>
    <disk type='file' device='floppy'>
      <driver name='qemu'/>
      <target dev='fda' bus='fdc'/>
      <alias name='fdc0-0-0'/>
      <address type='drive' controller='0' bus='0' target='0' unit='0'/>
    </disk>
    <disk type='file' device='cdrom'>
      <driver name='qemu'/>
      <target dev='hda' bus='ide' tray='open'/>
      <readonly/>
      <boot order='1'/>
      <alias name='ide0-0-0'/>
      <address type='drive' controller='0' bus='0' target='0' unit='0'/>
    </disk>
    <disk type='file' device='disk'>
      <driver name='qemu' type='qcow2' cache='unsafe'/>
      <source file='/home/myname/.local/share/libvirt/images/solaris10.qcow2'/>
      <backingStore/>
      <target dev='hdb' bus='ide'/>
      <boot order='2'/>
      <alias name='ide0-0-1'/>
      <address type='drive' controller='0' bus='0' target='0' unit='1'/>
    </disk>
    <controller type='pci' index='0' model='pci-root'>
      <alias name='pci.0'/>
    </controller>
    <controller type='fdc' index='0'>
      <alias name='fdc0'/>
    </controller>
    <controller type='usb' index='0' model='ich9-ehci1'>
      <alias name='usb'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x05' function='0x7'/>
    </controller>
    <controller type='usb' index='0' model='ich9-uhci1'>
      <alias name='usb'/>
      <master startport='0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x05' function='0x0' multifunction='on'/>
    </controller>
    <controller type='usb' index='0' model='ich9-uhci2'>
      <alias name='usb'/>
      <master startport='2'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x05' function='0x1'/>
    </controller>
    <controller type='usb' index='0' model='ich9-uhci3'>
      <alias name='usb'/>
      <master startport='4'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x05' function='0x2'/>
    </controller>
    <controller type='ide' index='0'>
      <alias name='ide'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x01' function='0x1'/>
    </controller>
    <interface type='bridge'>
      <mac address='CH:AN:GE:ME:PL:EASE'/>
      <source bridge='bridge0'/>
      <target dev='vnet0'/>
      <model type='e1000'/>
      <alias name='net0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x02' function='0x0'/>
    </interface>
    <serial type='pty'>
      <source path='/dev/pts/0'/>
      <target type='isa-serial' port='0'>
        <model name='isa-serial'/>
      </target>
      <alias name='serial0'/>
    </serial>
    <console type='pty' tty='/dev/pts/0'>
      <source path='/dev/pts/0'/>
      <target type='serial' port='0'/>
      <alias name='serial0'/>
    </console>
    <input type='mouse' bus='ps2'>
      <alias name='input0'/>
    </input>
    <input type='keyboard' bus='ps2'>
      <alias name='input1'/>
    </input>
    <input type='tablet' bus='usb'>
      <alias name='input2'/>
      <address type='usb' bus='0' port='1'/>
    </input>
    <input type='keyboard' bus='usb'>
      <alias name='input3'/>
      <address type='usb' bus='0' port='2'/>
    </input>
    <graphics type='spice' port='5900' autoport='yes' listen='0.0.0.0' keymap='it'>
      <listen type='address' address='0.0.0.0'/>
      <gl enable='no' rendernode='/dev/dri/renderD128'/>
    </graphics>
    <video>
      <model type='vmvga' vram='16384' heads='1' primary='yes'/>
      <alias name='video0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x03' function='0x0'/>
    </video>
    <memballoon model='none'/>
  </devices>
</domain>

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .