1

I have a Plantronics 590 bluetooth headset (the type probably does not matter, but I have no alternative to test).

Using the old 3.02 I was able to use this via pulseaudio. With the current 3.11-amd64 kernel this does no longer work.

I am still able to pair and to connect to the headset, using HSP profile. I get a "beep" on the headset to confirm connection. Unfortunataly there is neither input nor output in pulseaudio (with the old kernel pavucontrol shot the headset).

This is most likely related to the kernel or a module.

I am using debian testing (jessie).

  • The current version of linux-image-amd64 is 3.13+56
  • The current version of bluez is 4.101-4.1
  • The current version of pulseaudio and pulseaudio-module-bluetooth is 5.0-2
  • The current version of alsa-base is 1.0.25+3

I also tried debian stable (wheezy), 32bit, not working, but different: I can connect the device, it appears in pavucontrol but sound does not work.

  • The current version of linux-image-686-pae is 3.2+46
  • The current version of bluez is 4.99-2
  • The current version of pulseaudio and pulseaudio-module-bluetooth is 2.0-6.1
  • The current version of alsa-base is 1.0.25+3~deb7u1
  • In my experience it's generally rare that old hardware that was working stops. It's more likely that something is not configured properly. – slm May 14 '14 at 0:05
  • I got a hackisch workaroundisch solution, posted below. Maybe you can see what is configured wrong from that. If not I might be able to provide more information if you ask for it. – Fabian May 16 '14 at 12:38
1

This is not a good solution because it is quite hackish. But it is a work around. Maybe someone can find the real issue and provide a better solution. I suspect a bug somewhere.

I did the following (not sure if every step is essential):

  1. Created the file ${HOME}/.config/pulse/client.conf with contents

    autospawn = no
    

    (if the file already exists you can probably just add the line)

  2. Started pulseaudio manually from my session start script with

    pulseaudio -vvvv --log-time --log-target=file:${HOME}/var/log/pulseaudio.log &
    

    (you will need to adapt the log target, I suppose logging and verbose is not necessary, but it helps tracking down bugs)

  3. Start blueman-applet, turn on device, do anything you need to do to pair, this was not a problem for me.

  4. For some reason pulseaudio drops everything it knows about bluetooth at this point, so I do

    pactl load-module module-bluez4-discover
    pactl load-module module-bluez4-device
    
  5. Start pavucontrol and notice the device appears.

  6. Start mumble or Skype, or whatever. This should work now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.