I have Fedora 20, and am trying to install scanner software, 32-bit, for my Epson DX5000 printer. I get the messages:

[root@localhost:/home/Harry]$ rpm -Uvh iscan-2.29.3-1.usb0.1.ltdl3.i386.rpm 
error: Failed dependencies:
    libltdl.so.3 is needed by iscan-2.29.3-1.usb0.1.ltdl3.i386
[root@localhost:/home/Harry]$  yum install libltdl.so.3
Loaded plugins: langpacks, refresh-packagekit
No package libltdl.so.3 available.
Error: Nothing to do

I have tried searching on the Internet for libltdl.so.3, but I find the results very confusing. Is it perhaps part of another package? Please can anyone help me?

Thanks for the answers so far. I think this is another time when I asked X when I should have asked Y. I already have libtool installed (see the screen shot) So now the question is: why does it say libltdl.so.3 is needed when libtool is already installed? Unless I have misunderstood what is going on, again.

[root@localhost:/home/Harry]$ yum install libtool-ltdl
Loaded plugins: langpacks, refresh-packagekit
Package libtool-ltdl-2.4.2-23.fc20.i686 already installed and latest version
Nothing to do


[root@localhost:/home/Harry]$ yum install libltdl7
Loaded plugins: langpacks, refresh-packagekit
No package libltdl7 available.
Error: Nothing to do

Meta question: should I also change the title?

  • Looks like you want libltdl7. – Faheem Mitha May 13 '14 at 19:15

Whenever you encounter a stray missing library file such as this one you can use the command repoquery to find out what package provides it.


$ repoquery -q -f */libltdl.so*

I like to relax the query a bit and look for any .so files, so I've swapped the .3 out for a *.

NOTE: The above is quering (-q) for files (-f) matching the pattern (*/libltdl.so*). The first star is important since the query is looking for matches against the full paths of the files within the RPMs stored on the various YUM repos your system is aware of.


You have to install libtool-ltdl:

yum install libtool-ltdl

Source: https://www.google.com/search?name=f&hl=en&q=libltdl.so.3


This worked for me on Fedora 21 (x64):

rpm -Uvh iscan-2.30.1-1.usb0.1.ltdl3.x86_64.rpm --nodeps

ln -s /usr/lib64/libltdl.so.7 /usr/lib64/libltdl.so.3

iscan seems to work fine with the newer library

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.