3

I have some PDFs which, when viewed in readers under Linux (tried atril from MATE and evince from GNOME), the ligatures (e.g. fi, fl) are missing, as can be seen from the example (it should be specifications):

enter image description here

But when I view the same PDF in the built-in reader of Firefox (pdf.js) the ligatures are there; thus I know the PDF is not defective.

This looks like either this bug a missing font, but how to discover which one? This is the list of fonts in the PDF file:

enter image description here

I am using Debian unstable (jessie). What I have of fonts installed is

ii  ttf-bitstream-vera                    1.10-8                             all          The Bitstream Vera family of free TrueType fonts
ii  ttf-dejavu                            2.34-1                             all          transitional dummy package
ii  ttf-dejavu-core                       2.34-1                             all          transitional dummy package
ii  ttf-dejavu-extra                      2.34-1                             all          transitional dummy package
ii  ttf-mscorefonts-installer             3.5                                all          Installer for Microsoft TrueType core fonts
  • FWIW, I'm having the same issue in Debian testing (sid) – mhwombat Jul 30 '14 at 17:18
  • Oops, I meant unstable (sid). – mhwombat Jul 30 '14 at 17:31
1

This worked for me on Debian Jessie:

sudo aptitude remove fonts-texgyre

The behavior comes from the TexGyre fonts being substituted for Times and Helvetica when they appear in the pdf. I ended up installing it as one of the recommended packages of TexLive, so hopefully removing it won't break anything.

This answer was paraphrased from this Ubuntu bug report and confirmed in this one.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.