3

I'm running Debian 6 in a VM on a network that requires Windows authentication to a proxy server before it can run any http/https/ftp connection.

I've tried:

export http_proxy=http://domain\\username:password@proxyIPaddress:8080 

and same for ftp_proxy, but I keep getting: "Proxy server requires authentication".

My password does have a few special characters so I've escaped them using the backslash, just like I do for the domain name. If I hit the up arrow to view my history, the command looks correct (the escape backslashes are gone and the command and password look correct).

What else should I try?

2
  • I think you are colon missing password field. export http_proxy=username**:password**@[IP of Proxy Server]:[port]
    – TPS
    May 12, 2014 at 6:22
  • Tejas, I'm sorry, I should have written that. I am including the password. I'll edit the listing above.
    – Tensigh
    May 12, 2014 at 6:35

2 Answers 2

5

You should pass the export http_proxy command as a string. This should do the trick:

export http_proxy='http://domain\username@proxyIPaddress:8080/'
3
  • delta24, still no luck. I did pass it as a string and to confirm, I did "echo $http_proxy" and "echo $ftp_proxy". The strings do appear correct; password, domain, proxy and port.
    – Tensigh
    May 12, 2014 at 6:38
  • 1
    then I think your VM network config is not set up correctly. Use NAT if you're running VirtualBox.
    – delta24
    May 12, 2014 at 6:40
  • 2
    Dude, that was it. Thank you, you just saved me hours of work. In case anyone else tries this from the command line, special characters in passwords can be escaped using \ such as \@ if @ appears in your password.
    – Tensigh
    May 12, 2014 at 6:49
-1
export http_proxy=domain\\\username:password@proxyIPaddress:port

and

export https_proxy=domain\\\username:password@proxyIPaddress:port\

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .