4

I am trying to play a stream through mplayer. Here is the command I execute:

mplayer -user-agent "PS4 libhttp/1.60" -cache 8192 -v ffmpeg://http://the_stream_url.m3u8

The stream does not play due to a 403 - Forbidden error. This is expected if the user-agent is not correctly set. What makes me think the user-agent is not read correctly is that every HTTP request shows this user-agent instead:

User-Agent: Lavf/55.33.100

Is there anything I did not understand or do correctly?

Also note that I can correctly play the stream through VLC by using the same URL and :http-user-agent=PS4 libhttp/1.60 as the edit options.

Here is the full log, if needed.

1 Answer 1

3

This appears to be a bug in mplayer; if you omit ffmpeg:// prefix, custom user-agent is actually sent. Passing -lavfdopts o=user-agent=whatever also does not work.

1
  • Did that actually get fixed at some point? Feb 21, 2023 at 15:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .