0

When I try to open any graphical tool that demands the root password, it won't launch after I enter the password. I have tried the "Authentication" and "Date and Time" apps, for example. When I try to launch the app from the command line by typing system-config-authentication, it says:

No protocol specified
Unable to initialize graphical environment. Most likely cause of failure
is that the tool was not run using a graphical environment. Please either
start your graphical user interface or set your DISPLAY variable.

This happens whether I am using Gnome or KDE. This is on CentOS 6.5.

Edit: I installed CentOS as dualboot with windows 7 in laptop + i'm not using SSH and yes i'm in graphical environment when i run the command.

  • What exactly are you attempting to run....more details would really be nice and provide us with better quality of help. – mdpc May 10 '14 at 20:42
  • i just want to run the Authentication tool in the System Administration panel but i can"t it tell me to enter pswd root when i did nothing will happened and same thing to every application that demand pswd root. – Ismail Sensei May 10 '14 at 21:02
  • Are you in a graphical environment when you run these commands? – slm May 10 '14 at 21:14
  • Are you using this system directly? That is, have you installed CentOS onto the computer that is sitting right in front of you, and it is booted into CentOS? Or instead are you doing this through some indirection layer, such as a virtual machine or a shared web host? Are you using SSH, possibly with X11 forwarding? – Warren Young May 10 '14 at 21:50
  • I edited the post – Ismail Sensei May 11 '14 at 7:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.