3

The elinks program takes over the terminal to let you browse the web. But its behavior in the context of job control is wonky.

  1. If I CTRL-Z suspend an elinks session, and then try to resume it with fg, it works.

  2. If I CTRL-Z suspend an elinks session, and then run some other program to completion (e.g. find), and then try to resume it with fg, it just prints elinks or elinks [the URL I invoked it with] to STDOUT and hangs. Then if I to CTRL-Z suspend again and fg a second time, elinks resumes for real, taking over the screen.

What explains this behavior? Is there a way to fix it?

  • 2
    Have you tried using CTRL+L to force the terminal to redraw? Incidentally, you might find tmux or screen more useful than suspending elinks, also, did you know that elinks has an option to run an OS shell right from the File menu? just quit the shell to return to elinks. – etherfish May 8 '14 at 16:15
  • @etherfish Yes, CTRL-L does not fix the hanging problem. I'm also already using elinks inside tmux. The OS Shell file menu option is interesting, but pressing CTRL-Z would be better, since it's the standard way to escape. – dan May 8 '14 at 16:16
  • 2
    Debian fixed a bug about this odd behavior with elinks/links2 and bash, with 3 bugfixes - bugs.debian.org/cgi-bin/bugreport.cgi?bug=482395 - bugs.debian.org/cgi-bin/bugreport.cgi?bug=331409#57 - bugs.debian.org/cgi-bin/bugreport.cgi?bug=337159#30 - the browser and the shell are somehow handling on a messy way the SIGSTOP signal, and it could be related with your case... – user34720 May 8 '14 at 16:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.