6

My Ethernet adapter is somehow stuck at 10 Mbit/s. Here's the output of ethtool eth0:

Settings for eth0:
    Supported ports: [ TP MII ]
    Supported link modes:   10baseT/Half 10baseT/Full 
                            100baseT/Half 100baseT/Full 
    Supported pause frame use: No
    Supports auto-negotiation: Yes
    Advertised link modes:  10baseT/Full 
    Advertised pause frame use: Symmetric Receive-only
    Advertised auto-negotiation: Yes
    Link partner advertised link modes:  10baseT/Half 10baseT/Full 
                                         100baseT/Half 100baseT/Full 
    Link partner advertised pause frame use: Symmetric
    Link partner advertised auto-negotiation: Yes
    Speed: 10Mb/s
    Duplex: Full
    Port: MII
    PHYAD: 0
    Transceiver: internal
    Auto-negotiation: on
    Current message level: 0x00000007 (7)
                   drv probe link
    Link detected: yes

As you can see, my adapter supports 100 Mbit/s, and the "link partner" (my router?) supports 100 Mbit/s. However, if I manually set the mode to 100 Mbit/s using sudo ethtool -s eth0 speed 100 duplex full the link immediately disconnects.

How can I fix this problem?

  • 1
    how do you know it is the adapter that is the problem? There are number of things that could be an issue....what other troubleshooting have you done? – mdpc May 8 '14 at 4:36
  • How did I imply it's the adapter that is the problem? – ithisa May 8 '14 at 5:19
  • 1
    Connect the pc to another router or switch. Or connect another pc to the router using your wire. – davidbaumann May 8 '14 at 5:28
  • Other PCs use 100MiB/s correctly :/ – ithisa May 8 '14 at 5:47
  • Can you post the output of ethtool -i eth0, dmesg | grep eth0, grep . /sys/class/net/eth0/device/{subsystem_,}{device,vendor} and udevadm info --export-db | awk -vRS= /eth0/ – Stéphane Chazelas May 8 '14 at 10:51
4

Have you tried (while the system is on) turning the interface off and on? I'll assume that you have rebooted your system and this is something consistently happening.

Use a different cable. Bad cables or connectors do happen. Also of note, make sure you are using the right Cat of cable.

Use a different router/switch port. The router/switch port might be bad.

Examine configuration of router/switch port, is it auto negotiating? is the speed fixed? If you try to do auto on a port that has a fixed speed, I have seen what you have specified happen.

Some adapter boards do not properly do auto negotiation. If that is the case, then manually set both the router/switch port to a fixed speed.

Finally replace adapter board with new board and go through the troubleshooting including above.

Your final option is that the switch/router is bad.

  • 1
    I've tried everything. I turned autonegotiating off: it dies whenever I manually set 100 MiB/s. I connected the cable to another PC; works at 100 MiB/s. I am beginning to suspect this is simply a shitty interface (I bought it at a cheap Chinese store; it doesn't even have a brand on it) that falsely advertises 100 MiB/s support to the OS. – ithisa May 8 '14 at 6:41
  • do you have access to the router/switch? You sound as if this is not the case, I'd advise working with the site systems admin to verify the router/switch configuration. – mdpc May 8 '14 at 6:42
  • Why are you assuming so many stuff? I am simply at home, and I can configure anything about the router, and control the entire network. – ithisa May 8 '14 at 8:42
  • without information in the question, I can only guess. – mdpc May 8 '14 at 18:09
  • BTW, looks like it is time to get a new timex (adapter board) from what you are saying. – mdpc May 8 '14 at 18:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.