1

Once I finished installing elementary OS, it's all good.

After I did some changes for language, and switched it back, some symbols(unicode character?) are missing from terminal

enter image description here

those are two of missing symbols ‘╭─’ ‘╰─’

2

Your terminal is just using a font which doesn't have those glyphs. What you need to do is change the terminal or display manager settings to use a different font for fixed width text, and that should be it.

  • +1 A lot of variable width fonts don't implement these because they can't be used very effectively that way (although that actually looks like a monospace font to me, which is what you want in a terminal). It may also be a very obscure character (rounded corners...) -- I don't think any font implements the entire unicode set. – goldilocks May 7 '14 at 13:09
0

The picture shows the Unicode replacement character, which is displayed when attempting to show a byte that does not correspond to legal UTF-8 encoding.

The question hints at what happened:

After I did some changes for language, and switched it back, some symbols(unicode character?) are missing from terminal

for instance, if OP switched the locale to a non-UTF-8 encoding but did not change the terminal settings to use that encoding.

If a terminal simply lacks the appropriate character, it typically displays a box or empty space. It's not likely to show the replacement character for a legal (but absent from font) Unicode value. If your terminal does that, you should report it as a bug. Likewise, if it displays the replacement character when not configured for Unicode, that also is a bug.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.