0

so I'm following this tutorial to install php5 in a red hat 6.5 box and
I have only type one command and is this one below, I just wantend to install the php-gd module.(testing..)
when I try this:

yum --enablerepo=remi,remi-php55 install php-pecl-apc php-cli php-pear php-pdo php-mysqlnd php-pgsql php-pecl-mongo php-sqlite php-pecl-memcache php-pecl-memcached php-gd php-mbstring php-mcrypt php-xml

I get this error:

    Dependencies Resolved

    =======================================================================================    

    Package           Arch   Version          Repository                             Size
=======================================================================================
Installing:
 php-pecl-apc      x86_64 3.1.9-2.el6      rhel-x86_64-server-6                   96 k
 php-pecl-memcache x86_64 3.0.5-4.el6      rhel-x86_64-server-6                   60 k
 php-pgsql         x86_64 5.3.3-27.el6_5   rhel-x86_64-server-6                   70 k
 php54-mcrypt      x86_64 5.4.27-1.ius.el6 rackspace-rhel-x86_64-server-6-ius     25 k
 php54-mysqlnd     x86_64 5.4.27-1.ius.el6 rackspace-rhel-x86_64-server-6-ius    238 k
 php54-pecl-memcached
                   x86_64 2.2.0-1.ius.el6  rackspace-rhel-x86_64-server-6-ius     43 k
 php54-pecl-mongo  x86_64 1.5.1-1.ius.el6  rackspace-rhel-x86_64-server-6-ius    151 k
Installing for dependencies:
 libmcrypt         x86_64 2.5.7-5.el6      rackspace-rhel-x86_64-server-6-common  99 k
 libmemcached10    x86_64 1.0.16-1.ius.el6 rackspace-rhel-x86_64-server-6-ius    154 k
 libtool-ltdl      x86_64 2.2.6-15.5.el6   rhel-x86_64-server-6                   44 k
 php54-common      x86_64 5.4.27-1.ius.el6 rackspace-rhel-x86_64-server-6-ius    903 k
 php54-pdo         x86_64 5.4.27-1.ius.el6 rackspace-rhel-x86_64-server-6-ius     95 k

Transaction Summary
=======================================================================================
Install      12 Package(s)

Total download size: 1.9 M
Installed size: 0  
Is this ok [y/N]: Y
Downloading Packages:
(1/12): libmcrypt-2.5.7-5.el6.x86_64.rpm                        |  99 kB     00:00     
(2/12): libmemcached10-1.0.16-1.ius.el6.x86_64.rpm              | 154 kB     00:00     
(3/12): libtool-ltdl-2.2.6-15.5.el6.x86_64.rpm                  |  44 kB     00:00     
(4/12): php-pecl-apc-3.1.9-2.el6.x86_64.rpm                     |  96 kB     00:00     
(5/12): php-pecl-memcache-3.0.5-4.el6.x86_64.rpm                |  60 kB     00:00     
(6/12): php-pgsql-5.3.3-27.el6_5.x86_64.rpm                     |  70 kB     00:00     
(7/12): php54-common-5.4.27-1.ius.el6.x86_64.rpm                | 903 kB     00:00     
(8/12): php54-mcrypt-5.4.27-1.ius.el6.x86_64.rpm                |  25 kB     00:00     
(9/12): php54-mysqlnd-5.4.27-1.ius.el6.x86_64.rpm               | 238 kB     00:00     
(10/12): php54-pdo-5.4.27-1.ius.el6.x86_64.rpm                  |  95 kB     00:00     
(11/12): php54-pecl-memcached-2.2.0-1.ius.el6.x86_64.rpm        |  43 kB     00:00     
(12/12): php54-pecl-mongo-1.5.1-1.ius.el6.x86_64.rpm            | 151 kB     00:00     
---------------------------------------------------------------------------------------
Total                                                  930 kB/s | 1.9 MB     00:02     
Running rpm_check_debug
Running Transaction Test


Transaction Check Error:
  file /etc/php.ini from install of php54-common-5.4.27-1.ius.el6.x86_64 conflicts with file from package php-common-5.3.3-27.el6_5.x86_64
  file /usr/lib64/php/modules/curl.so from install of php54-common-5.4.27-1.ius.el6.x86_64 conflicts with file from package php-common-5.3.3-27.el6_5.x86_64
  file /usr/lib64/php/modules/fileinfo.so from install of php54-common-5.4.27-1.ius.el6.x86_64 conflicts with file from package php-common-5.3.3-27.el6_5.x86_64
  file /usr/lib64/php/modules/json.so from install of php54-common-5.4.27-1.ius.el6.x86_64 conflicts with file from package php-common-5.3.3-27.el6_5.x86_64
  file /usr/lib64/php/modules/phar.so from install of php54-common-5.4.27-1.ius.el6.x86_64 conflicts with file from package php-common-5.3.3-27.el6_5.x86_64
  file /usr/lib64/php/modules/zip.so from install of php54-common-5.4.27-1.ius.el6.x86_64 conflicts with file from package php-common-5.3.3-27.el6_5.x86_64
  file /usr/lib64/php/modules/pdo.so from install of php54-pdo-5.4.27-1.ius.el6.x86_64 conflicts with file from package php-pdo-5.3.3-27.el6_5.x86_64
  file /usr/lib64/php/modules/pdo_sqlite.so from install of php54-pdo-5.4.27-1.ius.el6.x86_64 conflicts with file from package php-pdo-5.3.3-27.el6_5.x86_64
  file /usr/lib64/php/modules/sqlite3.so from install of php54-pdo-5.4.27-1.ius.el6.x86_64 conflicts with file from package php-pdo-5.3.3-27.el6_5.x86_64

Error Summary

So I think nothing has happen yet. but I will like to roll back this transaction if possible so theres is no lost link somewhere that can ruin some configuration later on. I do have php 5.3.3 installed.

0

You need to add/install the remi YUM repository configurations before you can enable it. Directions for doing this are available here in this articled titled: Installing RHEL EPEL Repo on Centos 5.x or 6.x.

General steps for CentOS 6.x:

$ wget http://rpms.famillecollet.com/enterprise/remi-release-6.rpm
$ sudo rpm -Uvh remi-release-6*.rpm

As you stated, nothing has happened given the conflicts you're running into.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.