0

I had Xubuntu 12.10 running for a month or so without major problems. A few days ago after downgrad firefox from 29 to 28 by removing and reinstalling and upgrading system , the system blacked out and can't get into GUI ever again. The symptoms are:

log in screen fine, after logged in, a black screen with a white cursor stopped in the middle the screen, unmovable, everything stucked here.

I had tried to log in to tty1, and here I tried a few things:

  1. run startx, a small error window pops out saying "failed to load session "gnome"", and an button "log out", I clicked it and was brought back to tty1 seeing a lot of messages(*1)

  2. run lspci | -i VGA, it gives "00.02 0 VGA compatible ....Intel..integrated....." which is my integraded intel graphic card.

  3. run sudo apt-get --purge remove nivdia*, it gives 0 installed package to remove. so nothing to remove here.

  4. try to check file /etc/X11/xorg.conf, but no such file, instead there are several named a little bit different like xorg.conf.d*....

  5. I send a copy of /var/log/Xorg.0.log to my email and it is attached here http://paste.ubuntu.com/7403846/

3
  • Removing and re-installing firefox wouldn't do this. IT sounds like something else may have happened. By any chance do you recall what commands you typed to do this? you can check with: ctrl+alt+f1 log into text session. tail .bash_history (your history file may be named slightly differently). This info may tell us what happened. I have seem something similar where the users config file were chowned by root instead of the user. – Rqomey May 6 '14 at 12:31
  • Hi thanks! I did the downgrade/upgrade by using not only command but also synaptics and gdebi. so bash history might not reflect everythng. I can try upload that later though. What's worse is, just now while I was trying to fix it myself I accidently run update and upgrade! So I was upgraded from 12.10 to 14.10 Utopic now!!! there are more issues now. But from tty the system is still usable. what can I do to start over again with the system? thanks! here is the output of command"sudo cat lightdm.log" paste.ubuntu.com/7404667 – Shawn Ma May 6 '14 at 13:50
  • Failed to find lightdm-gtk-greeterAre you sure you have all dependencies installed? Maybe when you removed firefox you uninstalled your dependencies. Also, 14.10 is unstable, so at this version your system may break for whole new and different reasons. Try this apt-get -f install – Rqomey May 15 '14 at 7:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.