1

I'm having a problem with the wireless connection on a fresh install of Debian 7.4 which I didn't have before, I had Debian installed before and WiFi was working great, the only thing that changed this time is installing it from a live install image instead of the CD/DVD images.

My wireless card is Atheros AR5005G, and ath5k is already installed.

I'm trying to fix this problem and I searched about the issue but everything I found was about increasing txpower using iwconfig or setting power to off which is already off in my case.

So what could be the problem:

  • I remember that it was working fine on an old Debian distribution which had the madwifi driver
  • I'm dual booting Debian with Windows and on windows it's working fine
  • My laptop connects to the router without any problems
  • I had a live USB using the same image which had the same problem
  • I didn't have this problem before when I installed from the regular CD/DVD images
  • I have to be very close to the router to be able to access the internet
  • Pinging the router or any website takes a long time with many lost packets
  • 408 (Request Timeout) errors occur while browsing

Running lspci -v shows:

0a:03.0 Ethernet controller: Atheros Communications Inc. AR2413/AR2414 Wireless Network Adapter [AR5005G(S) 802.11bg] (rev 01)
    Subsystem: AMBIT Microsystem Corp. Device 0418
    Flags: bus master, medium devsel, latency 168, IRQ 18
    Memory at d0000000 (32-bit, non-prefetchable) [size=64K]
    Capabilities: [44] Power Management version 2
    Kernel driver in use: ath5k

Update:

Here are the dmesg related messages:

...
[7.485709] ath5k 0000:0a:03.0: registered as 'phy0'
...
[8.429871] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
[8.430578] ath5k phy0: Atheros AR2413 chip found (MAC: 0x78, PHY: 0x45)

And this is the full output of dmesg on pastebin.

  • Can you provide some information regarding your wireless hardware and what userspace tools do you use to connect to WiFi? – phoops May 6 '14 at 7:34
  • @edvinas.me sorry I forgot about that, I added the wireless card name. – Pierre May 6 '14 at 7:41
  • It worked previously with a Debian 7 installation from a regular CD/DVD image? This installation did not use madifi? Maybe your issue is connected with wrong CRDA (Central Regulatory Database Agent - country-specific settings for wireless) settings. Can you post via pastebin (or similar) related parts of your kernel messages (dmesg)? – jofel May 14 '14 at 12:25
  • @jofel I added the dmesg output to the question, and yes it worked before and it was a new Debian version 7.3 and I don't think it was using madwifi, because it's deprecated and replaced by ath5k, but it's working fine on Windows now and it worked on an old Debian live cd with madwifi. – Pierre May 14 '14 at 16:01
  • If you know another version is working why don't you install it (or run from a live) and check the differences? If it is only about the driver or there are other settings/apps. – Alex May 17 '14 at 15:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.