2

I installed Ubuntu 14.04 on VMware workstation version 10.0.0 on my Windows 7 machine. After installing I figured out that it doesn't have any sound so I checked the sound settings. All items seem to be at their default states and correct. Any suggestion to find the problem?

  • 2
    Do you install the vmware tools on your vm ? – Kiwy Jan 7 '15 at 6:21
0

If lspci|grep snd_ens1371 gives some output the sound kernel modules are loaded & sound is probably muted in alsamixer. Muted channels show up as 'MM' & can be unmuted by selecting them & pressing M.

If alsamixer does not detect a sound card run:

alsactl init

If you are using pulseaudio check /etc/asound.confcontains a minimum of:

pcm.pulse { type pulse }
ctl.pulse { type pulse }
pcm.!default { type pulse }
ctl.!default { type pulse }

I also changed the sound device settings in VMWARE to my detected speakers (from default host device).

Reboot & sound will work.

This fixed xfce4-volume-control / gstreamer complaining no sound card can be found & warning of a possible permissions problem. Trying to run just ALSA under Debian Wheezy 64 bit in VMWARE still gave this gstreamer error. VMWARE seems to run a little better with pulseaudio also being installed (sound in Virtualbox ran just fine with only ALSA).

0

Following command should resolve your issue:

sudo alsa force-reload

If that won't help you, try to reinstall ALSA and pulseaudio with these commands:

sudo apt-get remove --purge alsa-base pulseaudio

sudo apt-get install alsa-base pulseaudio

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.